Aller au contenu

Filament ABS

poulpe69

Réglage extrudeur

Messages recommandés

Bonjour, 

 

Cela fait pas mal de temps que je reporte ce sujet mais il semble qu'il faut que je le face vraiment.

 

Mais encore une fois, une chose que je ne sais pas faire lol.

Pour le moment je me suis contenté de mesuré 120mm sur le filament et demander a la cr10 d'extrudé 100mm par le boitier de commande de l'imprimante.

Et elle ne m'a extrudé que 71mm

 

Donc si quelqu'un se sent de me guider sur la marche a suivre, pour rappel je pige pas grand chose lol

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @poulpe69

On va essayer de faire simple.

Tu as demandé 100 mm d'extrusion, il n'est sorti que 71 mm donc il manque 29 mm.

Normalement, si tu connais la valeur actuelle des pas de l'extrudeur, une règle de trois permet de trouver la valeur nouvelle:

Nouvelle_valeur_pas = (100 / 71) x valeur_pas_creality      (ex: par défaut, Creality a paramétré le logiciel (firmware, Marlin) de la carte mère avec comme valeur pour le pas de l'extrudeur  à 93.00) donc on doit obtenir 100/71x93=130,9859 qu'on peut arrondir à 131

Pour pouvoir modifier cette valeur de pas pour l'extrudeur, plusieurs manières sont possibles que je n'ai pas toutes testées: via Pronterface, Repetier, Octoprint (via son terminal), éventuellement via le boitier de la CR10.

  • Via Octoprint, onglet Teminal, on va d'abord vérifier quelles sont les valeurs de pas stockées dans l'EEPROM de la carte mère via la comande gcode suivante: M503 (on valide) et des lignes s'affichent dans la fenêtre de terminal commençant par echo M92 ... E93.00 (valeur du pas actuel pour l'extrudeur); tu tapes ensuite la commande gcode suivante: M92 E131 puis tu valides (en pressant la touche ENTRÉE), vérifie à nouveau via M503 qu'elle a bien été prise en compte. Si oui, tu marques à nouveau ton filament à 120 mm et tu extrudes 100mm de filament puis tu mesures si c'est bon.   Si c'est pas bon retour à la règle de trois pour trouver la valeur du pas.
  • Via le boitier de la CR10: Control -> Motion -> Esteps/mm : 93.00 sélection en pressant le bouton puis en le faisant tourner jusqu'à obtenir la valuer calculée ci-dessus, presse le bouton pour valider. Marquer le filament à 120 mm , extruder 100mm, mesurer si tout est bon, sinon reprendre le calcul ci-dessus (règle de trois).

Une fois ta valeur de pas trouvée (celle qui te permet d'obtenir 100 mm de filament extrudé quand 100 mm demandé), il faut pouvoir la garder en mémoire. Normalement, il faut flasher le firmware avec la modification du pas. Mais on peut faire plus simple: si tu utilises Cura pour trancher les modèles à imprimer, on peut ajouter dans la section Start_gcode de l'imprimante la commande M92 Evaleur_pas-calculée ce qui fait que chaque modèle que tu trancheras aura la bonne valeur de pas. Exemple dans la copie d'écran ci-dessous, j'ai ajouté la ligne M92 E95 entre G28 et G1 Z5....

Voilà, en espérant avoir été simple pour quelqu'un qui pige pas grand chose 😉😄

cura-parametres-lpr.thumb.png.bca74e606e54a7a9692e97d124f9298b.png

  • +1 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Le premier truc, c'est de le refaire en demontant le tube de l'extrudeur.

Si tu as bien 100mm pour 100 demandé, c'est que la buse bouche...

Sinon, c'est le reglage de l'extrudeur...

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci les gars.

 

Je commencerai par ce qu'a dit volavoile, car c'est vrai qu'il me faut vérifier si ma buse n'est pas en cause ou partiellement en cause.

Et dans la foulée je passerais aux choses qu'a dit fran6p (super bien détaillé merciiiiiiiiii).

 

Je vous tiens au courant dans la soirée je pense

Partager ce message


Lien à poster
Partager sur d’autres sites

Donc, je viens de le refaire sans passer par la buse et il y a un léger mieux 77mm au lieu de 71.

Donc la buse est en partie en cause et le réglage également si j'ais tout compris.

J'ais donc voulu essayer de modifier par le boitier avec comme valeur.

100/77x93 = 120.7792 ce qui ferais 121 arrondi.

Par contre j'ais un souci.

Quand je passe par Control je n'ais que Temperature et Restore Failsafe comme option.

Partager ce message


Lien à poster
Partager sur d’autres sites

Du coup j'ais fais la correction directement dans cura tapant M92 E120.779

J’espère que c'est bon

Seulement il me reste des soucis 

J'ai voulu imprimer un cube creux de 20x20 et des parois de 0.5

il fait dans la réalité 19.96 d'un coté et 20.1 de l'autre et les parois font de 0.55 a 0.68 la hauteur de 20 a 20.1

 

Et il y a un gros défaut a 15mm de haut environ

A part le gros défaut le reste est ok malgrés que sur la photo ça parais grossier de visu c'est vraiment bien (impression en 0.1)

Des idées a me soumettre sur le cube ainsi que sur le réglage de l'extrusion?

 

20180630_202235.jpg

20180630_202242.jpg

Modifié (le) par poulpe69

Partager ce message


Lien à poster
Partager sur d’autres sites

Les dimensions du cube de 20mm sont plutôt bonnes, voire très bonnes ! Par contre les dimensions de la parois me font penser à un problème de flux (flow) ou à un filament qui varie en diamètre.

On dirait pour le défaut que c'est un manque de matière (sous-extrusion). Qualité du filament? Diamètre du filament qui varie? Problème de température? Qualité du fichier STL? Problème de trancheur? Je ne sais pas trop; peut-être qu'en fournissant plus d'informations (type de filament (PLA ou autre), température tête/plateau, vitesse, etc...) on pourrait sérier les problèmes 😉 ).

Partager ce message


Lien à poster
Partager sur d’autres sites

Donc l'impression a était faite avec du PLA de chez grossiste3d blanc naturel avec un diamètre a une moyenne de 1.73

a 215° pour la tête et le plateau a 60

vitesse de 60mm/s

Je trouve ce filament plutôt collant

Les cubes ont était créé sous tinckercad et transformés par cura.

Partager ce message


Lien à poster
Partager sur d’autres sites

Le filament sur la bobine est bien enroulé? N'y aurait-il pas un noeud (ça arrive parfois) qui aurait freiné la fourniture de matière à l'extrudeur puis le noeud ayant finalement réussi à se "dénouer" la matière aurait à nouveau pu couler correctement et finir la pièce.

Facile à vérifier: tu déroules quelques mètres de filament et tu verras rapidement si ça coince quelque part.

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis encore très novice mais je te donne quand même mon avis sur ta photo..

Il peut arriver que ton filament accroche mal sur la roue denté de l'extrudeur, résultat: quand ton filament est correctement entraîné par la roue, impression ok, mais par contre si il glisse sur cette roue il y a alors un manque de matière à certain moment uniquement comme sur ta photo

Dans mon cas, je tirais 100mm je n'avais que 69, je réessayais j'avais 78, puis 63... jusqu’à m'apercevoir que le filament n’était pas toujours entraîné par la roue l'extrudeur

A voir..

Modifié (le) par David590

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 10 heures, fran6p a dit :

Le filament sur la bobine est bien enroulé? N'y aurait-il pas un noeud (ça arrive parfois) qui aurait freiné la fourniture de matière à l'extrudeur puis le noeud ayant finalement réussi à se "dénouer" la matière aurait à nouveau pu couler correctement et finir la pièce.

Facile à vérifier: tu déroules quelques mètres de filament et tu verras rapidement si ça coince quelque part.

Non pas de nœuds sur la bobine 

Il y a 2 heures, David590 a dit :

Je suis encore très novice mais je te donne quand même mon avis sur ta photo..

Il peut arriver que ton filament accroche mal sur la roue denté de l'extrudeur, résultat: quand ton filament est correctement entraîné par la roue, impression ok, mais par contre si il glisse sur cette roue il y a alors un manque de matière à certain moment uniquement comme sur ta photo

Dans mon cas, je tirais 100mm je n'avais que 69, je réessayais j'avais 78, puis 63... jusqu’à m'apercevoir que le filament n’était pas toujours entraîné par la roue l'extrudeur

A voir..

A priori pas de souci de ce coté.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je suis en train de régler l'extrudeur de ma CR10S, en passant par la ligne de commande d'octoprint.

J'arrive à passer les commandes pour le réglage, et à rentrer la nouvelle valeur à l'aide de la commande M92 Exxx.

Lorsque je veux sauvegarder la nouvelle valeur sur l'EEPROM par la commande M500, j'ai Ok pour l'exécution de la commande, mais l'EEPROM n'est pas mis à jour.

Quelqu'un a t il une idée ?

Je retiens comme solution de remplacement la solution de fran6p : mettre à jour Cura.

Merci

Jean Luc 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Pour généraliser ma question ci dessus, est - il possible de modifier des paramètres en entrant des commandes via le terminal d'octoprint et de les sauvegarder sur l'EEPROM, sans avoir à flasher la CR10S.

Merci

Jean Luc

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour Jean Luc:

Salut,

Apres ton M500 (sauvegarde des modifs), fais un M501 (charge les modifs).

En fait, tu as bien sauvegardé mais pour appliquer tes modifs, sans redemarrer l'imprimante,

il faut faire un M501 pour charger la nouvelle configuration.

Pour ta question sur les modifs de l'eeprom sans flashage depuis octoprint, c'est oui pour certains éléments , mais pas pour tout.

Modifié (le) par masterz

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour ta réponse masterz

 

Par contre, lorsque je fais M501, voilà ce que ça donne

octoprint.jpg.b1ea498461f84bdab35ff1076e0e6dc7.jpg

Et il ne prend pas en compte les modifications bien sur.

Pour les motifs de l'eeprom, je pense à des modifications de valeur pour certains éléments aussi.

Jean Luc

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

pour palier au même problème de mémorisation des step dans ma cr10s j'ai tout simplement mis les M92 dans le gcode de start de cura

;prog du: {date} {time}

G21                     ;metric values

;ICI CE SONT DES PARAMETRES PROPRE A MA MACHINE:
M203 Z15.00 E100.00 ;ici j'ai modifié les vitesse maxi Z et Extrudeur
;DEFINITION DES STEP
M92 X79.9254373871603 ; step en X
M92 Y79.995105249141  ; step en Y
M92 Z401.036          ; step en Z
M92 E98.95            ; step en E

G90                     ;absolute positioning
M82                     ;set extruder to absolute mode
M107                    ;start with the fan off
G28 X0 Y0               ;move X/Y to min endstops
G28 Z0                  ;move Z to min endstops
G0 Z50.0  F4000.    ;Degagement a Z 50 pour attente chauffe
M117 Chauffage...
M190 S{material_bed_temperature}
M109 S{material_print_temperature}

G92 E0                  ;zero the extruded length
G1 F200 E20          ;extrude 15mm of feed stock
G92 E0                  ;zero the extruded length again
M0                       ;ICI le M0 pour nettoyer la buse

M117 Impression...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

 

Merci pour ta réponse Titi78, c''est ce que je vais faire, à défaut de comprendre pourquoi on ne peut pas écrire sur l'eeprom (problème de droit ?)

J'ai vu également qu'on peut mettre des commandes GCODE dans octoprint setting -> printer -> GCODE scripts :

Before print job starts

After print job completes

After print job is cancelled

After print job is paused

Before print job is resumed

Before tool change

After tool change
After connection to printer is established

Before connection to printer is closed

Je vais regarder aussi de ce côté, en particulier, lorsqu'il y a un conflit entre le GCODE imprimable et le paramètre (logiquement en cas de même commande, le GCODE imprimable devrait remplacer la commande qui est dans before).

 

A+

Jean Luc

Modifié (le) par JL76

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, JL76 a dit :

à défaut de comprendre pourquoi on ne peut pas écrire sur l'eeprom (problème de droit ?)

Peut-être tout simplement que le firmware de Creality n'a pas activé l'option de sauvegarde de l'EEPROM dans leur Marlin 😉 .

Citation

// @section extras

// EEPROM
// The microcontroller can store settings in the EEPROM, e.g. max velocity...
// M500 - stores parameters in EEPROM
// M501 - reads parameters from EEPROM (if you need reset them after you changed them temporarily).
// M502 - reverts to the default "factory settings".  You still need to store them in EEPROM afterwards if you want to.
//define this to enable EEPROM support
#define EEPROM_SETTINGS

#if ENABLED(EEPROM_SETTINGS)
  // To disable EEPROM Serial responses and decrease program space by ~1700 byte: comment this out:
  #define EEPROM_CHITCHAT // Please keep turned on if you can.
#endif

Pourtant d'après leur code source (ci-dessus), il semble activé 🤔

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 51 minutes, fran6p a dit :

Peut-être tout simplement que le firmware de Creality n'a pas activé l'option de sauvegarde de l'EEPROM dans leur Marlin 😉 .

Pourtant d'après leur code source (ci-dessus), il semble activé 🤔

Merci pour ta réponse,

Je vais essayer de regarder si j'ai la même version de firmware, ou s'il y a un moyen de voir si cette option est activée.

J'hésite encore à flasher ma CR10S, car pour l'instant, je n'en ai pas vraiment besoin, et j'ai toujours peur de tout casser et de ne pas pouvoir revenir en arrière.

A+

Jean Luc

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...