Aller au contenu

Filament ABS

WrathOfThePixel

Bondtech BMG, inversion moteur et reglage du pas

Messages recommandés

Bonjour bonjour

Je me suis procuré un extrudeur Bondtech BMG pour ma CR-10S. J'ai une petite question pour le montage, avant de faire une bêtise quelconque.

Dans la notice, ils proposent de changer la polarité du moteur en inversant deux fils dans la fiche de celui-ci, ainsi que régler le pas moteur avec un M92 E415 dans l'en-tête GCode. Je n'ai pas vraiment envie d'aller modifier cette fiche, je me demandais donc si mettre un pas négatif (M92 E-415) pourrait régler du même coup le sens de rotation sans bidouiller les câbles ?

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites

Parfois quand on met le moins l'imprimante ne comprend plus rien et bug. Au pire tu peux la flasher avec marlin et inverser le moteur et régler les step dans marlin

Envoyé de mon SM-N960F en utilisant Tapatalk

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 12 minutes, fran6p a dit :

C'est un peu dommage qu'une valeur négative ne soit pas valide. C'est le firmware qui veut pas ? Une version plus a jour l'accepterais, peut-être ? J'ai vraiment pas envie de modifier le câble, surtout que si j'ai bien compris, le BMG fonctionne à l'envers en bowden, et à l'endroit en direct (ou alors un truc m'échappe). Pour le moment je vais le mettre en bowden mais je n'exclus pas de le passer en direct à l'avenir. Je n'avais pas non plus envie de me lancer dans la mise à jour du firmware avant d'avoir fini un projet en cours, au cas où quelque chose se passe mal et que je me retrouve bloqué. Pouvoir changer ça dans le GCode m'aurais permis de profiter de l'extrudeur sans trop de prise de tête en attendant "les gros travaux" pour plus tard.

Bon ben il va rester dans sa boite encore un petit moment, du coup.

Merci pour vos réponses.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 11 minutes, WrathOfThePixel a dit :

le BMG fonctionne à l'envers en bowden, et à l'endroit en direct

???

Comment cela se pourrait-il? En direct le filament arrive d'un côté et ressort de l'autre et en bowden, le filament arrive d'un côté et ressort de l'autre 🙂  donc c'est le même fonctionnement ou alors il y a quelque chose qui m'a échappé 😉 .

Honnêtement, changer la disposition des câbles sur la fiche, c'est très facile (on lève la petite languette sur la fiche et on tire délicatement le câble). Le seul truc à ne pas oublier est éventuellement de mettre une étiquette sur ce câble pour se souvenir ultérieurement que la connexion est inversée.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 10 minutes, fran6p a dit :

???

Comment cela se pourrait-il? En direct le filament arrive d'un côté et ressort de l'autre et en bowden, le filament arrive d'un côté et ressort de l'autre 🙂  donc c'est le même fonctionnement ou alors il y a quelque chose qui m'a échappé 😉 .

Honnêtement, changer la disposition des câbles sur la fiche, c'est très facile (on lève la petite languette sur la fiche et on tire délicatement le câble). Le seul truc à ne pas oublier est éventuellement de mettre une étiquette sur ce câble pour se souvenir ultérieurement que la connexion est inversée.

et bien voilà comment il se monte en bowden :

image.thumb.png.f7ec2e3c93adc6c65d2b8de1772fbf21.png

Et en direct :

maxresdefault.jpg

 

Donc j'ai peut-être pas tout compris, c'est pas improbable, mais j'ai quand même l'impression que le sens de passage du fil est inversé.

 

edit : quant au bidouillage de câble, même si c'est pas compliqué, c'est probablement pas vraiment fait pour (surtout avec mes gros doigts), la manip logicielle est toujours plus perenne et modifiable à volonté. Mais c'est que mon point de vue, après chacun fait comme il se sent le mieux.

Modifié (le) par WrathOfThePixel

Partager ce message


Lien à poster
Partager sur d’autres sites

Tu te fais un petit cable adaptateur avec 2 connecteurs en inversant.... simple non...Pour le pas inutile de flasher si tu ne veux pas te lancer la dedans moi j ai simplement enregistré dans l eprom...  Au pire tu me le revends si tu me fais un bon prix...!

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, thsrp a dit :

Tu te fais un petit cable adaptateur avec 2 connecteurs en inversant.... simple non...Pour le pas inutile de flasher si tu ne veux pas te lancer la dedans moi j ai simplement enregistré dans l eprom...  Au pire tu me le revends si tu me fais un bon prix...!

Non j'ai pas l'intention de le vendre 😂 Je ne crois pas qu'on puisse flasher en EEPROM facilement avec le firmware original ? Je n'avais pas l'intention de modifier le firmware avant d'avoir fait toutes les modifs que j'avais en tête, principalement parce que c'est pénible d'amener le PC à l'imprimante pour l'USB, à cause de la configuration de ma (toute petite) maison, et mon octoprint a décidé de ne plus octoprinter pour le moment, encore un truc ajouté sur la pile des chose à faire un jour peut-être. Pouvoir changer ça provisoirement dans le GCode aurait-été la solution parfaite.  Mais du coup je vais mettre ce firmware à jource soir, j'en ai marre d'imprimer à 30mm/s avec un flow de malade pour obtenir quelque chose qui tient à peu près debout.

 

il y a 34 minutes, volavoile a dit :

vraiment pas compliqué d'inverser les cables...

Soit les deux intérieurs, soit les deux extérieurs, soit les 4...

Les deux extérieurs dans ce cas. Et puis il faudra que je le refasse quand j'aurais décidé de passer en direct. Et sans doute encore une fois si je veux changer le moteur pour un plus petit, parce que celui fourni me semble lourd pour du direct. Je ne dis pas que c'est compliqué, évidement tout le monde peut le faire. Je trouve juste un peu dommage de modifier du matériel (et donc potentiellement raccourcir sa durée de vie), alors qu'il y a du logiciel pour gérer simplement ce genre de paramètre. Mais c'est juste une question de point de vue. Quelqu'un issu de l'électronique plutôt que de l'informatique pensera sans doute exactement l'inverse 😉

Modifié (le) par WrathOfThePixel

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello,

Honnêtement, inverse les 2 câbles, ça se fait en 30 secondes avec un petit tournevis par exemple. Et si un jour tu décide de repasser sur un autre extrudeur, tu peux facilement remettre la configuration de ton câble d'origine.

Ou sinon comme déjà dit, tu passes sur Marlin ou autre firmware et tu inverse le sens de rotation, comme ça pas besoin de modifications de ton câble.

Et pour la valeur négative... au pire tu test, si ça fonctionne et bien c'est parfait, sinon il faut donc procéder a une des 2 étapes ci-dessus 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites

 Est-ce qu'il y a une différence de construction entre la CR-10 et la CR-10S à ce niveau là (marque rouge) ?

extrud.jpg.98cc2f7617d430a290a817c3240ecca7.jpg

Par erreur j'ai pris un support pour CR-10, je me suis dit que ça n'était pas grave du fait que je n'utilise pas le détecteur de fin de fil, mais j'ai l'impression que l'axe fileté  bloque le support et l'empêche de loger à sa place...

Modifié (le) par WrathOfThePixel

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 34 minutes, WrathOfThePixel a dit :

 Est-ce qu'il y a une différence de construction entre la CR-10 et la CR-10S à ce niveau là (marque rouge) ?

Non. Aucune différence. Ces pattes métalliques et les noix en laiton sont identiques sur les CR10, 10S, Ender3...

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, fran6p a dit :

Non. Aucune différence. Ces pattes métalliques et les noix en laiton sont identiques sur les CR10, 10S, Ender3...

Merci. En regardant mieux je crois qu'il y a un petit défaut d'impression sur le support, un petit coup de lime et ça va mieux. C'est pas dramatique, mais pour le prix du bidule, ils pourraient vérifier ça d'un peu plus près...

Avec ce montage, le câble du moteur frotte sur ce même axe fileté du coup, pas terrible non plus.

 

Edit : en passant, j'ai mis à jour Marlin, mais je ne trouve pas comment réactiver la fonction "Auto bed leveling" présente dans le firmware d'origine. Si quelqu'un à une piste... Merci d'avance.

Edit bis : Bon, première impression avec le bidule très enthousiasmante, je peux enfin imprimer à vitesse normale. Manifestement celui que j'ai eu avec l'imprimante était défectueux, il faudra que je l'autopsie à l'occasion.

Ceci dit, je trouve le chargement du fil très laborieux : pas moyen de débrayer les roues d'entraînement sans dérégler le serrage, donc il faut parcourir tout le PTFE juste à la force du moteur. Ça prend une éternité. Idem pour retirer le fil, on en est à deux éternités. Et au moment où le bout du fil arrive enfin dans l'extrudeur, c'est le drame. La buste ayant légèrement déformé l'extrémité du fil, ça ne passe plus. Impossible de le retirer sans 1. défaire le réglage cité plus haut, 2. y aller à la pince coupante tout contre les roues d'entraînement (et c'est à ce moment qu'on se rappelle le prix écrit sur la facture en serrant les fesses). Alors j'exclus pas d'avoir fait une bêtise quelque part, mais pour le moment je me dis qu'il y a quand même un gros défaut de conception... J'ai en ce moment un bout de PLA coincé dans l'extrudeur et je vois pas comment l'enlever sans tout redémonter.  Si c'est le même cirque à chaque impression, je vais peut-être bien finir par le refiler pour une bouchée pain au premier venu 😕

Modifié (le) par WrathOfThePixel

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, BDA a dit :

Yop ! 

Pour le bed leveling sans capteurs tu peux utiliser ce tuto : http://www.cr10.fr/activation-du-mesh-bed-leveling-ou-comment-se-passer-dune-sonde/
Ça fonctionne super bien et c'est facile à utiliser. 🙂

Ah merci, j'avais vu ces options dans les sources de Marlin mais c'était pas très clair. J'ai remis ça à plus tard, parce que depuis que j'ai installé le nouvel extrudeur, mon plateau se dérègle constamment, parfois en cours d'impression. Je pense pas que ça soit lié mais du coup faut que j'aille voir ce qui se passe la dessous... Je garde ton lien sous le coude en attendant.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×