Aller au contenu

Filament ABS

Jufik

Impression via Octopi

Messages recommandés

Bonjour à tous, 

cela fait quelques mois que j'en chie je m'amuse avec ma U20.
J'ai énormément appris, notamment grâce à ce forum, quand bien même un bon nombre de mes prints foirent .... mais bon... c'est un process 🙂

J'utilise une Pi (3B+) pour controller mon imprimante.
Côté slicer, j'utiliser Slic3r PE qui me donne satisfaction... seulement voilà: que ce soit via Slic3r, Cura - ou n'importe quel autre soft', l'imprimante  n'affiche rien quant aux informations de l'impression en cours. En fait, il ne se passe rien et je peux continuer de pianoter sur l'écran tactile en plein milieu d'un print.

Ça ne me posait aucun soucis jusqu'au jour ou j'ai voulu faire une "pause" au milieu de l'impression (pour une insertion d'écrou dans une piéce).
Il ne se passe strictement rien... pas de pause...

J'envoie bien le code "M117" pour annoncer le début d'un print, la "pause" est bien dans le GCode... mais ça ne fonctionne pas, la flavor du GCODE est bien Marlin.
Quelqu'un a déjà eu ce soucis? Est ce que je loupe un truc ?

Partager ce message


Lien à poster
Partager sur d’autres sites

@screech car j'ai un insert à faire sur une impression qui dure 6h environ.... 
J'ai refait un test avec Cura et ça a fonctionnait.... mais c'est Octopi qui met en pause et pas l'imprimante.

Reste à régler un autre soucis: lors de la reprise, ça n'adhère pas même en chauffant comme un malade....

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 12/01/2019 at 21:39, Jufik a dit :

@screech car j'ai un insert à faire sur une impression qui dure 6h environ.... 
J'ai refait un test avec Cura et ça a fonctionnait.... mais c'est Octopi qui met en pause et pas l'imprimante.

Reste à régler un autre soucis: lors de la reprise, ça n'adhère pas même en chauffant comme un malade....

Ba c'est normal. C'est OctoPrint qui pilote ton imprimante quand tu imprime depuis ce dernier...

Partager ce message


Lien à poster
Partager sur d’autres sites

je confirme, c'est le firmware de l'Alfawise qui ne prends pas en charge l'affichage des messages en dehors de l'impression fait par elle même.c'est à dire de la fenêtre d'impression sur l'Alfawise.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ca, tu peux faire un petit fichier texte/gcode qui fait "rien" que tu mets sur la carte SD. L'imprimante restera sur cet écran de controle de l'impression... tantque tu n'appuies pas sur the bouton stop...

Modifié (le) par Epsylon3

Partager ce message


Lien à poster
Partager sur d’autres sites

Oh malin ^^ je n'y avais pas pensé 😛

Par contre du coup comme on est sur l’écran d'impression, peut on envoyer des M117 depuis Octoprint pour afficher des messages sur l'écran ?

Faut que je test ^^

 

EDIT : Testé avec un Gcode qui contenait juste : "M117 Printing" Et bein l'imprimante à pas l'air d'aimer 😉 elle fige, et reboot :S 

Modifié (le) par screech

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, screech a dit :

Oh malin ^^ je n'y avais pas pensé 😛

Par contre du coup comme on est sur l’écran d'impression, peut on envoyer des M117 depuis Octoprint pour afficher des messages sur l'écran ?

Faut que je test ^^

 

EDIT : Testé avec un Gcode qui contenait juste : "M117 Printing" Et bein l'imprimante à pas l'air d'aimer 😉 elle fige, et reboot :S 

Envoyer un GCode vide à l'imprimante fait boucler le firmware pour tenter de savoir quoi faire sans y parvenir. Lui envoyer en plus une autre commande alors qu'elle ne sait même plus où elle en ait peut fait saturer et déclenche un reboot 😉 

Modifié (le) par CacaoTor

Partager ce message


Lien à poster
Partager sur d’autres sites

Un objet vide je voulais dire, qu'il y ait juste l'init sans impression... J'ai deja laissé l'imprimante sur cet écran apres une impression de la SD et octoprint fonctionnait.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour à tous,

j'ai également un problème de pause mais à partir d'Octopi pour insérer un écrou dans un logement qui se termine à la couche 10 (pour l'exemple). Dans Ultimaker Cura 3.6, j'essaye d'utiliser "Extensions -> Post Processing -> Modifier le G-code" comme sur l'image, le G-code est bien modifié.

La séquence se déroule très bien, sauf qu'à la reprise, manuelle dans Octopi, l'extrusion ne fonctionne plus, j'ai seulement les mouvements de rétraction qui me font reculer le filament, m'obligeant à stopper l'impression. Je n'ai pas trouvé la liste officielle des G-codes de la U20 si elle existe, ce qui m'aurait aidé à trouver ce qui cloche.

Questions: Quels sont les G-codes relatifs à l'extrusion/rétraction dans l'Alfawize?

Voyez-vous quoi faire pour réactiver l'extrusion après la pause ?

Merci de votre aide.

 

Le post traitement, (Standby Temperature est à 205):

1594778298_Capturedcran_2019-02-02_16-05-42.png.6d52249cb2e28ce98729308a7b2732f4.png

 

Un extrait du G-code produit pas Cura:

;TYPE:WALL-OUTER
G1 F1800 X140.2 Y159.8 E90.63496
G1 X140.2 Y140.2 E90.88075
G1 X159.8 Y140.2 E91.12654
G1 X159.8 Y159.8 E91.37233
G0 F8400 X159.6 Y159.8
G0 X159 Y159.118
;MESH:NONMESH
G0 X141.159 Y141.159
;TIME_ELAPSED:207.988583
;TYPE:CUSTOM
;added code by post processing
;script: PauseAtHeight.py
;current layer: 10
M83
G1 F1500 E-6
G1 F300 Z3.1
G1 F9000 X190 Y190
G1 F300 Z15
M104 S205; standby temperature
M0;Do the actual pause
M109 S205; resume temperature
G1 F1500 E6
G1 F199.998 E6
G1 F1500 E-6
G1 F300 Z3.1
G1 F9000 X141.159 Y141.159
G1 F1500 E6
G1 F9000
M82
G92 E91.37233
;LAYER:10
;MESH:xyzCalibration_cube.stl
G0 X141.159 Y141.159 Z2.3
;TYPE:FILL
G1 F3600 X158.839 Y158.839 E91.68588
G0 F8400 X158.13 Y158.839
G1 F3600 X158.839 Y158.13 E91.69846

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour info, finalement c'est un bug de Cura résolu dans la V4.0.1 dans laquelle, le même script ne pose pas de probléme.

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...