Aller au contenu

Filament ABS

Mad_noob

Supprimer un home offset

Messages recommandés

Bonjour,

J'ai remplacé le magnet autocollant et le buildtak, par une vitre (5mm) avec un buildtak autocollant parce que le lit d'origine était concave.

J'ai adapté une première fois la position du fin de course Z pour que ma buse soit au dessus du lit à un écart que je pensais pouvoir compenser avec les vis de réglages du lit.

J'ai voulu (dans ma logique) faire en sorte que l'imprimante prenne comme nouveau "0" la nouvelle position de l'axe Z qui était à +1.4mm en cliquant avec la molette Set home offset...

Étant donné que j'ai fait ça avant de finaliser mes réglages de calibration lit/buse (comme un gros malin 🙂) et que j'ai du retoucher au fin de course (parce que l'écart que pensais compenser était trop important), je me retrouve avec un home + offset.

Actuellement je recherche une méthode pour pouvoir effacer cet offset et lancer une impression de test. Est-ce qu'il va falloir forcément que rentre dans la firmware de l'imprimante ?

Merci par avance

Mad'

Partager ce message


Lien à poster
Partager sur d’autres sites

@Mad_noob

La Ender 3 (pro ou pas) peut récupérer les valeurs d'origine du firmware sans avoir besoin de reflasher l'imprimante (d'autant plus que la carte de ton imprimante n'est pas équipée d'origine d'un chargeur de démarrage (bootloader) dont l'installation est nécessaire avant de pouvoir flasher une nouvelle version de Marlin).

Via le menu du boitier tu peux accéder  à l'option Control, Restore failsafe qui récupérera les valeurs du firmware pour les remettre en EEPROM.

Les menus du boitier de contrôle: LCD Menu Tree.pdf

Modifié (le) par fran6p
erreur
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Salut @Janpolanton

De quel lien on parle? J'ai joint un document pdf qui donnent la composition des menus du boitier de contrôle mais rien d'autre. Et je n'ai pas compris (je dois sans doute être mal réveillé 🙂 ) le post de @trotro 😉 .

Partager ce message


Lien à poster
Partager sur d’autres sites

Ok 😄

Mes gros doigts ont malencontreusement confondu la touche Suppression et Entrée d'où l'édition dans la foulée de mon message.

On aurait aussi pu se dire que je lui donnais la note afin  qu'il s'accorde 😉 

Modifié (le) par fran6p
trop vite, pas relu ;-)
  • Haha 3

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 20 heures, fran6p a dit :

@Mad_noob

La Ender 3 (pro ou pas) peut récupérer les valeurs d'origine du firmware sans avoir besoin de reflasher l'imprimante (d'autant plus que la carte de ton imprimante n'est pas équipée d'origine d'un chargeur de démarrage (bootloader) dont l'installation est nécessaire avant de pouvoir flasher une nouvelle version de Marlin).

Via le menu du boitier tu peux accéder  à l'option Control, Restore failsafe qui récupérera les valeurs du firmware pour les remettre en EEPROM.

Les menus du boitier de contrôle: LCD Menu Tree.pdf

Bonjour,

Merci pour vos réponses 🙂

Finalement dans le menu de l'Ender 3 Pro au même emplacement j'ai l'option "Initialize EEPROM" que j'ai cliqué et cela s'est appliqué.

Entre temps j'ai aussi trouvé le manuel avec les commandes sur le site de Marlin : http://marlinfw.org/docs/gcode/M206.html

J'ai passer les commandes avec un OctoPrint sur mon PC fixe (j'ai pas encore de Raspberry PI). Au final je pense qu'il n'y a plus d'offset.

Par contre j'ai toujours un soucis pour imprimer le chien de test, au moment de lancer l'impression, au lieu de démarrer à 0 l'axe Z ajoute 0.2 du coup rien ne colle...

Une idée pour retirer ces 0.2 ? J'ai bien vue une option hauteur de la couche dans CURA, mais de ce que j'en comprends cela va jouer sur le fait de tasser plus ou moins la couche d'impression ?

Merci 🙂

EDIT : Un autre truc, c'est que quand tu laisse l'imprimante connecté en USB cela allume l'écran de l'imprimante, mais l'éclairage est pas au max. Est-ce que ça vous le fait ?

Modifié (le) par Mad_noob
Précision

Partager ce message


Lien à poster
Partager sur d’autres sites

@Mad_noob

Pourrais-tu joindre le gcode du "chien" afin de voir ce qu'il contient comme commandes?

Partager ce message


Lien à poster
Partager sur d’autres sites

@fran6p

Le voici. La ligne 27 du fichier gcode donne la position d'origine (je présume) et pour Z elle indique 0.200. Dois-je mettre 0 à la place pour que mon axe Z soit en "endstop" et que l'écart entre ma buse et le lit soit comme je l'ai réglé (épaisseur d'une feuille) ?

J'ai dû zipper le fichier, il faisait 16mo...

Test-dog.zip

Partager ce message


Lien à poster
Partager sur d’autres sites

@Mad_noob

Voici le début du fichier commenté :

Citation

M190 S50.000000
M109 S200.000000
;Sliced at: Tue 13-03-2018 09:03:51
;Basic settings: Layer height: 0.15 Walls: 1.2 Fill: 15  "La hauteur de couche du modèle est de 0,15mm"
;Print time: 5 hours 7 minutes
;Filament used: 13.088m 39.0g
;Filament cost: None
;M190 S50 ;Uncomment to add your own bed temperature line
;M109 S200 ;Uncomment to add your own temperature line
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops  "Le "homing" pour chaque axe est correct (0,0,0)"
G1 Z15.0 F3600 ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F3600
;Put printing message on LCD screen
M117 Printing...

;Layer count: 578
;LAYER:0
M107
G0 F3600 X83.288 Y86.266 Z0.200 "Apparemment la hauteur de la première couche est plus grande que les suivantes, c'est une option qu'on peut utiliser dans le trancheur pour normalement assurer une meilleure accroche (quand je tranche mes modèles, la première couche a la même valeur que les suivantes 0,2 )"
;TYPE:SKIRT

Je ne vois rien d'anormal dans ce début de gcode.

Le principe, quand la mise à zéro des trois axes a été effectuée, c'est de lever la buse de la hauteur de couche demandée, sinon la matière extrudée n'aurait aucun espace pour s'écouler (comme sur le dernier dessin ci-dessous).

Exemple sur ce schéma (propriété de @Bosco2509 😄😞

Hauteurs_buse_1ere_couche.png.c7c8d99105af3e8c801d87072bb1c349.png

Éventuellement tu pourrais tester en remplaçant la valeur de 0,2 par celle correspondant à la hauteur des couches suivantes: 0,15.

Je ne me souviens plus si tu as indiqué sur quelle surface tu imprimes et à quelle température (je suis ballot, pour la température c'est indiqué dans le gcode 50° pour le lit).

J'imprime rarement avec une température aussi basse pour le lit, plutôt 65° pour la première couche puis 60° pour les suivantes. Ça fonctionne très bien avec mon plateau (feuille de PEI), je n'ai jamais de pièces qui se décroche 😉 .

Tu peux éditer le gcode (c'est un fichier texte) avec un bon éditeur (Notepad++ sous Windows, Vi / Nano sous Linux). Tu remplaces :

M190 S50.000000  par M190 S60

et

G0 F3600 X83.288 Y86.266 Z0.200  par G0 F3600 X83.288 Y86.266 Z0.15

Tu enregistres et tu testes.

  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites

En fait j'avoue ne pas trop comprendre pourquoi on rajoute une épaisseur en plus de l'écart entre la buse et le lit au réglage initial ?

L'idée en mettant 0.15 c'est de réduire l'écart entre la buse et le lit (schéma du milieu) ? Remarque mon réglage initial de lit est peut être un peu bas, ce qui fait qu'avec les 0.20 du gcode la buse se retrouve un poil trop haut (schéma d'en haut).

En fait j'ai un buildtak de marque Creality autocollant que j'ai appliqué sur une glace claire de 235x235x5 commandé chez un miroitier. Finalement c'est sans doute moins efficace pour la conduction thermique de la base du lit vers le buildtak (quand la base du lit est à 60° m'étonnerai que la surface du buildtak le soit également). Quant aux températures ce sont celles du gcode, autrement j'ai préréglé à 200°C - 60°C (Pre-Heat PLA dans Menu Prepare).

Je vais faire un essai sur tes bons conseils car j'aimerai vraiment pouvoir en tirer quelques chose.

Je trouve que le réglage du plateau c'est pas de la tarte 😀

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 13 minutes, Mad_noob a dit :

Je trouve que le réglage du plateau c'est pas de la tarte 😀

C'est un coup à prendre mais une fois qu'on l'a acquis, c'est tout bon 😉 . Je n'ai pas de système d'auto-nivellement sur ma CR10. Il est rare que je re-règle mon plateau hormis quand je change de buse ou que je démonte la tête. (j'ai changé la buse il y a plus de deux mois et je n'ai pas retouché au nivellement depuis).

il y a 14 minutes, Mad_noob a dit :

En fait j'avoue ne pas trop comprendre pourquoi on rajoute une épaisseur en plus de l'écart entre la buse et le lit au réglage initial ?

Le réglage du niveau est indépendant de la hauteur de couche. On utilise la technique de la feuille de papier légèrement pincée uniquement pour s'assurer que l'axe X et le plateau sont parallèles. Certains utilisent même des cales plus hautes (1 ou 2 cm par exemple @Titi78 ). Peut importe l'épaisseur de cette cale, ce qui est important c'est de d'assurer que le parallélisme entre la buse (fixée sur l'axe X) et le plateau est bon en tout point du plateau.

Cette technique permet de s'assurer que le "homing" est bien en position (0,0,0). Une fois qu'on est certain de cela, le trancheur sait qu'en levant la tête / buse de la hauteur de couche, elle sera parfaitement déposée.

Il faut trouver la bonne technique même si ce n'est pas évident au début (j'ai mis un certain temps à la maîtriser 😄 ) car c'est la base d'une bonne accroche, de la même manière qu'une construction ne sera jamais d’aplomb si sa base n'est pas correcte (sinon le premier loup qui passe par là, en soufflant dessus fera tout effondrer 😉 ).

Modifié (le) par fran6p
erreur / complément et Bescherelle ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vais refaire mon réglage initial de lit parce que ma feuille n'est pas légèrement pincée... J'ai modifié le fichier et je ferai une impression test ce soir, je dois bouger sous peu.

Merci pour ton aide, je mettrais mes résultats dès que possible. 😉

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

Je reviens vers vous pour vous dire que j'ai refais mes réglages de lit et j'ai pu imprimer un cube d'étalonnage XYZ trouver sur thingiverse. J'utilise la version 4 de CURA pour découper le fichier et pour le moment je me familiarise avec.

J'ai imprimé des clip pour la nappe de l'écran à venir le rail support à la base de l'imprimante.

Je posterai des photos ce soir pour que vous me donniez un avis sur ces pièces, si une amélioration est nécessaire.

@+ tard et merci pour votre aide en tout cas 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Mad_noob a dit :

merci pour votre aide en tout cas

De rien. C'est le principe du forum: aider quand on le peut 😉 .

Pour remercier un contributeur, tu peux aussi cliquer sur le cœur au bas de son post (il offre aussi d'autres possibilités 😉 ). Ça permet de réagir / d'indiquer son "opinion" sans forcément devoir compléter par écrit un post. 

barre_icones_forum_explications.png.220b13e2e226da1129875cf7680eea69.png

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...