Aller au contenu

Filament ABS

[ENDER 3 PRO] Buse qui ne touche pas le plateau !


Messages recommandés

Bonjour tout le monde,

Je possède une ENDER 3 PRO, avec un BLTouch installé. Je n'ai jamais touché le firmware, donc je ne peux pas vous dire duquel il s'agit...

J'ai pu imprimer quelque truc après installation du BLTouch, mais les impressions étaient imprécises: comme si le plateau n'était pas "droit", si j'imprimais un carré, certains bord était plus épais que d'autres etc... Mais je pouvais imprimer ! >_<

Aujourd'hui, après quelques réglages "manuels", sous entendu pas logiciel, mais bien à coup de vis (l'axe étant plus droit, la buse bougeait etc), je me retrouve avec une buse qui est bien à 3/4mm au dessus du plateau.

Le problème ? Les ressorts sont déjà déssérés au maximum, et le réglage de Z-offset ne change rien ! Que je sois à +6 ou -6, c'est la même chose.

Donc je suis persuadé que je fais quelque chose de mal...

Donc, j'ai besoin d'aide 😄

Encore merci !

Edit: Aucun possibilité de faire les tests de la buse/plateau sans faire une impression ?  Parce que chauffer le plateau et la buse à chaque fois que je touche un réglage prends du temps... 😞

Modifié (le) par Alexandre Noel
Lien à poster
Partager sur d’autres sites

Tu l'as acheté d'occasion toute montée ?

Si non, alors comment as-tu fait pour installer le bltouch qui n'est pas d'origine ?

Sinon commences par les tutos cela va te guider et permettra à chaque étape de trouver un problème ou d'éliminer une cause possible.

Lien à poster
Partager sur d’autres sites

Bonjour,

donc une Ender 3 Pro avec Bltouch, Bltouch que tu as ajouté ?

tu ne connais pas le firmware, mais il faut le modifier pour avoir le Bltouch actif sur une Ender 3, l'as tu fait ?

Lien à poster
Partager sur d’autres sites

Merci pour vos réponses rapides 😉

Alors non, elle était neuve bien entendue. Je l'ai utilisé une année à peu prés, puis j'ai voulu l'améliorer un peu. Avec entre-autre un BLTouch.

Donc, j'ai suivi toutes les étapes, et oui j'ai bien flashé quelque chose. Mais je crois avoir lu un peu partout le fameux "Marlin". Et je ne crois pas avoir poussé ça dans l'imprimante. Il me semblait que c'était juste une update du firmware. Après c'est peut-être un autre firmware directement 😄

Edit: Aucune idée de savoir quel est le firmware actuel ?

Modifié (le) par Alexandre Noel
Lien à poster
Partager sur d’autres sites
il y a 9 minutes, Alexandre Noel a dit :

Donc, j'ai suivi toutes les étapes

Lesquelles ?

il y a 10 minutes, Alexandre Noel a dit :

j'ai bien flashé quelque chose.

Oui mais quoi? Firmware récupéré où?

il y a 10 minutes, Alexandre Noel a dit :

Et je ne crois pas avoir poussé ça dans l'imprimante.

Comment exactement ?

Si tu veux que des membres du forum puissent t'aider, plus tu fourniras d'informations détaillées, accompagnées éventuellement de photos (carte mère, manière de connecter le BLT sur icelle, …), plus l'aide apportée sera facilitée.

🙂

  • Haha 1
Lien à poster
Partager sur d’autres sites

Cela fait plus d'un an que j'ai poussé ça... Je ne saurai plus dire qu'elle est la version ou autre.

J'ai suivi les instructions fournis avec le manuel du BLTouch. "BLTouch for Creality V1 Mainbord"
J'ai updaté avec le logiciel progisp.exe et de mémoire la Chip ATmega1284p.

Après, si cela peut aider à débugguer un peu le bazar, je peux repousser une version que vous m'indiquez, histoire de partir sur une base propre et non bancale avec mes renseignements flous...!

Lien à poster
Partager sur d’autres sites

Salut,

Si ça t'intéresse, je suis en train de faire la manip avec @Myrmidou ici. Tu peux utiliser le firmware que j'ai préparé ici.

Attention: n'oublie pas le M503 avant le flashage, qui permet de lire les valeurs de l'eeprom = réglages que tu as déterminés pour ta machine (plus d'infos ici pour la communication USB + installation du driver USB, Pronterface,...). Attention, le lien renvoie vers une carte différente qui ne se flashe pas de la même manière (carte SD) et la commande M43 n'est pas activée, ni la sauvegarde de l'eeprom (pas assez de place sur ta carte mère).

Après flashage, la 1ère chose à faire est de tester le BLTouch:

0- la led du BLTouch est rouge fixe (si elle clignote, c'est qu'il y a un défaut)
1- tu sors la touche: M280 P0 S10
2- tu tapes: M119 (pour voir l'état des fins de course).
3- tu enfonces la touche à la main (normalement, la led change de couleur, bleue normalement )
4- tu retapes: M119 (l'état du fin de course Zmin a dû changer)
5- tu rentres la touche: M280 P0 S90

Tu peux suivre également ce sujet (même carte que toi mais le firmware n'est pas utilisable car il n'avait pas besoin du lecteur de carte SD, il communique en USB avec un Raspberry pi)

  • +1 1
Lien à poster
Partager sur d’autres sites

Le GCode M503 te permet de visualiser les valeurs stockées dans l'eeprom qui contient les paramètres que tu as réglés pour ta machine (pas/mm pour chaque moteur,...).

Tu trouveras l'ensemble des GCodes pour Marlin et leur signification ici (et pas en chinois 🤣!)

Lien à poster
Partager sur d’autres sites

Marlin est un firmware (programme de la carte mère) open-source assez facilement paramétrable. Lorsqu'il est paramétré, on le compile pour générer un fichier exploitable par la carte-mère. Dans un premier temps, je te propose de passer cette étape (c'est moi qui l'ait faite) et tu n'as qu'à utiliser le fichier compilé = firmware. Si tu le souhaites, je reviendrai sur la compilation lorsque le firmware sera fonctionnel sur ta machine.

Lien à poster
Partager sur d’autres sites
Il y a 8 heures, Alexandre Noel a dit :

On dirait quand même un sacré bordel, juste pour corriger un truc de base

Libre à toi de suivre une autre voie, je t'indique seulement une/ma solution. Mais j'ai l'impression que tu n'as pas vraiment régler ta machine et que passer un peu de temps à tout reprendre de zéro serait bénéfique pour la suite. Ce n'est que mon avis bien sûr. 😉

Lorsque le fonctionnement du BLTouch est validé, tu peux suivre ces instructions à partir de l'étape 2.

Attention, comme le microcontrôleur de ta carte mère a une taille mémoire programme limitée, j'ai dû enlever certaines fonctionnalités de Marlin, notamment la sauvegarde (M500). Ce n'est pas grave, il suffira d'écrire les paramètres spécifiques de ta machine dans le gcode de démarrage du trancheur (slicer type cura,...)

Modifié (le) par remibora
  • +1 1
Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Créer...