Aller au contenu

Filament ABS

  • 0

Décalage énorme axe Z / z-offset


Question

Salut à tous,

J'utilise mon Ender3 équipée d'un BLtouch depuis près d'un an, et elle a eu bien des soucis, mais là je crois que j'innove. En tout cas je n'ai pas réussi à trouver pareil souci sur le forum. Alors voilà : tout allait bien, j'imprime une pièce et tout se passe bien. Je recommence (même pièce, même filament, aucun changement de quoi que ce soit) et ça se passe encore bien. Et la troisième fois, c'est la cata.

Et depuis rien à y faire !

Le souci ? Quand je fais "auto home", la buse se positionne bien, le leveling se passe bien. Mais ensuite, quand je mets par exemple en motion/axe Z/0 l'axe Z remonte à environ 5cm du plateau. J'ai mesuré, j'ai éteint la machine, réessayé, exactement au même niveau : très très haut.

Pas question de compenser ça avec le Z-offset, il faudrait lui donner comme valeur -51,... ce qui n'est pas du tout normal vous en conviendrez.

Alors, avant de tout péter d'énervement, je me tourne vers vous : une bonne âme a-t-elle déjà vu ça ? Qu'est ce que j'ai fait de mal pour obtenir ça ?🤔

Merci d'avance😊

Lien à poster
Partager sur d’autres sites

Messages recommandés

  • 0

As-tu vérifié tes excentriques ?

As-tu vérifié que ta tige filetée soit bien en contact avec le moteur dans le coupleur ? 

La noix en laiton de la tige filetée ne doit pas être complètement serrée afin de laisser un peu de jeu ?

Lien à poster
Partager sur d’autres sites
  • 0

Ouh là... Plein de mots que je comprends à peine. Dans l'ordre :

1) merci de m'avoir répondu

2) les excentriques c'est les écrous qui tiennent les roulettes des charriots sur les axes ? si c'est ça, je veux bien vérifier mais comment ça peut impacter l'axe Z seulement ?

3) comment on vérifie ça ?

Lien à poster
Partager sur d’autres sites
  • 0

Alors les excentriques c'est là ou y'a des roues qui fonctionnent par trio et y'en a 1 qui possède un réglage.

On peut desserrer et resserrer en fonction que les axes coulisses sans accroc/fluide (en disable motor fonction dans ton menu pour désactiver les moteurs afin de pouvoir bouger les axes a la main) et tes axes doivent se tenir également.

La noix en laiton qui tient ta tige filetée ne doit pas être serrée a fond laissant la possibilité à ta tige filetée de légèrement bouger au besoin.

Enfin le coupleur qui est la chose grise et ronde, qui repose sur ton moteur Z et dans lequel il y'a ta tige filetée doit être correctement montée.

tout cela afin de vérifier que ton axe Z répond correctement aux demandes. 

Je te joints des tutos:

Lien à poster
Partager sur d’autres sites
  • 0

Attention, tous aux abris, la copine de Thor est de retour 😖🤣...

Salut @olivia87,

Effectivement, c'est une nouveauté cette histoire. Je vais encore t'embêter, mais en plus des vérifications demandées, est-ce que tu pourrais brancher un ordinateur à l'imprimante via USB? Si c'est possible, pourrais-tu nous fournir la liste des paramètres de l'eeprom en envoyant un M503 (avec Pronterface par exemple)? tu pourras mettre le résultat dans un fichier texte pour le joindre à ton message.

Que se passe-t-il lorsque que tu envoies un G28 (prise d'origine) puis un G0 Z0 F100 (déplace la buse à Z = 0)?

PS:

Il y a 3 heures, olivia87 a dit :

Qu'est ce que j'ai fait de mal pour obtenir ça ?

Tu as la mémoire un peu courte: tu as voulu l’assommer à coups de marteau 🤣. Résultat: elle se venge en te faisant devenir chèvre! ces petites bêtes là sont très rancunières, tu sais 😫!

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites
  • 0

Salut

Citation

ton axe Z répond correctement aux demandes. 

--> oui, l'axe Z répond parfaitement, l'axe est bien positionné et répond pile poil sans accroc, sans hésitation, sans écart.

Citation

tes axes doivent se tenir également

--> les axes X et Y fonctionnent bien. Les "excentriques" y semblent bien, les courroies sont tendues comme avant, ni trop peu ni trop.

J'ai refait un essai, après avoir coupé la machine un bon moment. Même symptôme : auto home donne bien le bon résultat, mais ensuite toute commande sur l'axe Z envoie ~5cm plus haut. J'ai réussi à obtenir la mesure : 51.3mm exactement Après avoir re-éteint et rallumé, même résultat, même écart au dixième de mm près.

Un indice sur votre écran maintenant : j'ai remarqué que la jambe du BLtouch était un peu penchée (juste un peu genre 5° dans le sens horaire), je l'ai redressée. Puis j'ai tout rallumé. Et re-testé. Sniff, rien de mieux.

@remibora : je n'ai pas d'ordinateur à côté de l'imprimante, mais je vais essayer d'apporter un ordi portable. Tu as un tuto/lien pour la manip à faire stp car je ne connais pas Pronterface.

Merci

 

Citation

tu as voulu l’assommer à coups de marteau

J'y pense, mais je ne l'ai pas encore fait.

Pas encore...

Lien à poster
Partager sur d’autres sites
  • 0

Je vais te répondre la même chose que la dernière fois 😜: voir ce message. Pour mémoire, tu avais déplacé l'imprimante vers l'ordi et non l'inverse 😉.

PS: les modérateurs apprécient moyennement les multi-posts (commentaires consécutifs de la même personne). Tu peux modifier ton commentaire pendant 12h en cliquant sur l'icone "..." en haut à droite puis sur Editer.

Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

Oui je me souviens, c'était déjà un beau bazar. Du coup, pour Pronterface... je vais essayer. Souhaite moi bonne chance !

 

Alors voici les résultats (tu vois j'ai édité le message au lieu d'en poster un nouveau, ah là là)

>>> m503
SENDING:M503
echo:  G21    ; Units in mm
echo:  M149 C ; Units in Celsius
echo:Filament settings: Disabled
echo:  M200 D1.75
echo:  M200 D0
echo:Steps per unit:
echo:  M92 X80.00 Y80.00 Z400.00 E93.00
echo:Maximum feedrates (units/s):
echo:  M203 X300.00 Y300.00 Z5.00 E25.00
echo:Maximum Acceleration (units/s2):
echo:  M201 X500 Y500 Z100 E1000
echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo:  M204 P500.00 R500.00 T1000.00
echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
echo:  M205 S0.00 T0.00 B20000 X10.00 Y10.00 Z0.40 E5.00
echo:Auto Bed Leveling:
echo:  M420 S0 Z0.00
echo:Material heatup parameters:
echo:  M145 S0 H200 B50 F255
  M145 S1 H240 B70 F255
echo:PID settings:
echo:  M301 P20.84 I1.96 D55.47
echo:Z-Probe Offset (mm):
echo:  M851 Z-3.31




>>> G28
SENDING:G28
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing

(tout se passe bien on finit au bon endroit)

>>> G0 Z0 F100
SENDING:G0 Z0 F100

(on revient gentiment au 5cm trop haut, rien d'autre)

Donc on n'a pas trop avancé, hein...

Modifié (le) par olivia87
ajout de réponse
Lien à poster
Partager sur d’autres sites
  • 0

Si tu envoies un M206, il te répond quoi?

PS: éditer un message, c'est bien. Le soucis, c'est qu'on est pas alerté de la modif. Heureusement que tu as répondu à mon message 😉

EDIT: que se passe-t-il lorsque tu palpes le plateau avec un G29 suivi d'un M500 pour enregistrer? Est-ce que la buse remonte toujours après un G28 et un G0 Z0 F100?

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites
  • 0

Eh oui, c'est pour ça que l'idée d'éditer au lieu de re-répondre a clairement été abandonnée un peu partout, mais bon chaque modo son règlement 😝

Alors voici ce que ça donne avec M206 :

>>> M206
SENDING:M206

Et puis... rien ne se passe, rien ne bouge.

Lien à poster
Partager sur d’autres sites
  • 0

Tu connais le petit nom de ta carte-mère? V1.1.4/ v1.1.5/V4.2.2?

il y a 7 minutes, olivia87 a dit :

Eh oui, c'est pour ça que l'idée d'éditer au lieu de re-répondre a clairement été abandonnée un peu partout, mais bon chaque modo son règlement

tu voudrais pas voter ici dans ce cas 🤣... même si ça ne changera rien au final 😜. Le but était seulement de trouver un compromis.

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites
  • 0

Non, je ne connais pas son nom, mais si tu veux je peux tout démonter pour le trouver... à coup de disqueuse et de masse de chantier, si ça continue, je vais craquer 🥵

Lien à poster
Partager sur d’autres sites
  • 0

Merci ! J'envie ta patience !!

La réponse est : 1.1.14

Il ne m'a fallu que deux vis... Erreur dans un passé lointain lors du montage ?

Lien à poster
Partager sur d’autres sites
  • 0

C'est ce que je craignais... par contre comme tu as un bltouch, tu as déjà mis à jour le firmware, non?

PS: je suis un gros imbécile, je pensais avoir laissé 1 mois pour le vote alors que j'ai mis le 7 juin 😩... y'en a qui méritent des baffes!!!

Lien à poster
Partager sur d’autres sites
  • 0
Citation

C'est ce que je craignais...

Est-il donc notoire que cette version précisément est susceptible d'outrageusement rendre folles les utilisatrices en faisant des bugs sans raison ?

(indice : toute réponse positive conduira la bête à la déchetterie, avec pertes et fracas, pour être remplacée par une moins pénible à utiliser)

Citation

y'en a qui méritent des baffes!!!

Approche ta joue, ça me défoulera... et puis, c'est à la mode la giffle aujourd'hui 🤣

Lien à poster
Partager sur d’autres sites
  • 0

Je ne pense pas qu'on n'ait besoin d'en arriver là 🥴...

il y a 43 minutes, olivia87 a dit :

La réponse est : 1.1.14

Peut-on poursuivre en MP?

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites
  • 0
Il y a 12 heures, remibora a dit :

même si ça ne changera rien au final

Absolument 😉

Lien à poster
Partager sur d’autres sites
  • 0

Salut @olivia87

Non.

La carte mère v1.1.4 d'origine ne possède pas de chargeur de démarrage donc pour installer un nouveau firmware soit on en installe un en préalable soit on passe par une clé USBASP connectée sur la prise ICSP de la carte et en utilisant un programme comme ProgISP pour installer en même temps un firmware avec le chargeur de démarrage.

Tu as donc normalement dû réaliser une des deux procédures. Si c'est le cas, après flashage du nouveau firmware, l'EEPROM a bien été remise à zéro (M502 + M500) ?

<Mode 😄 >

Peut-être que ton imprimante est envoûtée ? Faire appel à un exorciste ou le marabout du coin (celui qui met ses flyers dans la boite à lettres) reste la dernière solution avant son élimination pure et simple.

</Mode 😄>

🙂

Lien à poster
Partager sur d’autres sites
  • 0

Merci fran6p, mais... do you speak martien ? Franchement j'ai relu plusieurs fois ta phrase, et même en y mettant de la bonne volonté je n'ai pas tout compris. Mais je vais essayer !

 

Un grand merci public à Maître @remibora, grand manitou des médiums désenvoûteurs !

Grâce à ses talents télépathiques, il a réussi à réparer mon Ender 3. Bravo, et merci !!💯

  • Haha 1
Lien à poster
Partager sur d’autres sites
  • 0

C'est pas moi M'sieur l'agent, j'étais même pas là 😖!

En réalité, j'ai rien compris 😅 🤣... pourvu que ça dure 🤞

Peut-être qu'un M502, fait par inadvertance, a solutionné le problème 🤔...

Modifié (le) par remibora
Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...