Aller au contenu

Filament ABS

systemic

Touch Mi de Hotends.fr (Auto bed leveling)

Messages recommandés

Hello

J'ai acheté et viens de recevoir le nouveau capteur de hotends.fr. 

Je viens de commander et de recevoir le capteur touch mi du site hotends.fr pour essayer de l'adapter sur ma i3 mega.

Ça a l'air pas mal et il faudra juste trouver/designer le support du capteur sur la hotend. Si j'arrive à quelque chose, je donnerais des infos ici et si quelqu'un d'autre se lance dans la même aventure, je veux bien avoir du feedback. (les infos de la doc du site sont pour l'instant que pour des Cr10).

 

Voila la vidéo et le lien vers la doc :

 

http://www.hotends.fr/fr/home/64-capteur-auto-leveling-touch-mi.html

 

J'ai une première question pour les experts. (genre @Murdock, @thsrp, @db42, @stef_ladefense ):

J'ai besoin d'une entrée sur la trigorilla et je sais pas ce qui est le mieux. J'ai déjà pas compris avec tou ce que j'ai lu si il y en a une de libre ou si il faut que je "cannibalise" le détecteur de filament (qui me sert jamais).

Une fois cette question réglée, je me lancerai pour un test à l'arrache et ensuite sur la création du support avec fusion au niveau de la hotend.

 

Systemic

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ajoute @Fourmi au cas ou il aurait quelque chose à signaler ici...

Partager ce message


Lien à poster
Partager sur d’autres sites

Evidemment si je mets pas @fourmi :-) Si "hotends" lui même peut aider ça sera encore plus simple. 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité

Tu en as plusieurs de libres notamment les pins servo qui sont facilement accessibles. Ou bien tous ceux de exp1

Modifié (le) par Invité

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour l'information. J'avais vu ton analyse et aussi le commentaire de Murdock il me semble sur les erreurs de la fiche technique de la trigorilla. Je vais voir ce qui est le plus simple et le plus accessible et me faire un test cette semaine. 

Les servos me paraissent une excellente idée. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Je suis ton post avec intérêt

Partager ce message


Lien à poster
Partager sur d’autres sites

1- @systemic Connecte le capteur sur la broche Z_Min ( broche en bas à droite  "Z-") et ça ira tout seul, regarde bien le brochage !!

  • S> Fil Jaune
  • G> Fil Noir
  • V> Fil rouge

Ensuite pour le firmware si tu es sous Marlin ,tu peux regarder ce que j'ai mis Page 4.

No stress on va t'aider ;) 

5

2- Pour le montage sur ton imprimante 

Le plus important> ton capteur une fois le PIN rentré doit se trouver entre 1 mm et 2.5 mm au dessus du bas de la buse.
Tu pourras renseigner la position du capteur dans le firmware ( Offset par rapport a la hotend).

Et pour le module d'activation,  si tu me donnes quelques côtes j'peux te faire STL ;)

@ bientot !!

Modifié (le) par Fourmi

Partager ce message


Lien à poster
Partager sur d’autres sites

J'avoue que c'est assez tentant pour les v2 qui non pas de capteur d'autolevel. Ont viens tous juste d'avoir le firmware d'anycubic, ça tombe très bien tous ça ^_^

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci tout le monde. @Fourmianycubic a la tendance de réaffecter les pins pour se faciliter la vie et en plus mettre des cartes filles avec un gros tas de colle pour pas que ça bouge. Du coup, le pin Servo sont une bonne idée (pin 11 par exemple qui est déjà toute prête).

Pour le montage dans un premier temps, je vais faire le test en manuel sans l'aimant en montant le capteur directement sur un cache hotend que j'avais imprimé (celui de base étant en métal et n'ayant pas de trou disponible comme sur la Cr10). Juste un trou à la bonne hauteur (et la plaque de derrière le circuit imprimé devrait faire l'affaire. 

Ensuite pour le firmware, je vais aller modifier et recompiler et faire un test j'espère d'ici demain soir. 

Finger crossed. 

Je mets 3 photos pour expliquer en image ce que je viens de dire. 

IMG_20180307_080112.jpg

IMG_20180307_080032.jpg

IMG_20180307_080156.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

Je disais juste de le mettre sur le Z_MIN, par simplicité aprés oui on peut le mettre ou on veut tant qu'on affecte les pins dans le firmware.

Et pour la position sur le chariot,tu peut aussi le mettre a droite et mettre un bout de Gcode aprés le "home" pour aller activer le capteur, tout est possible ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 17 heures, systemic a dit :

Hello

J'ai acheté et viens de recevoir le nouveau capteur de hotends.fr. 

Je viens de commander et de recevoir le capteur touch mi du site hotends.fr pour essayer de l'adapter sur ma i3 mega.

Ça a l'air pas mal et il faudra juste trouver/designer le support du capteur sur la hotend. Si j'arrive à quelque chose, je donnerais des infos ici et si quelqu'un d'autre se lance dans la même aventure, je veux bien avoir du feedback. (les infos de la doc du site sont pour l'instant que pour des Cr10).

 

Voila la vidéo et le lien vers la doc :

 

http://www.hotends.fr/fr/home/64-capteur-auto-leveling-touch-mi.html

 

J'ai une première question pour les experts. (genre @Murdock, @thsrp, @db42, @stef_ladefense ):

J'ai besoin d'une entrée sur la trigorilla et je sais pas ce qui est le mieux. J'ai déjà pas compris avec tou ce que j'ai lu si il y en a une de libre ou si il faut que je "cannibalise" le détecteur de filament (qui me sert jamais).

Une fois cette question réglée, je me lancerai pour un test à l'arrache et ensuite sur la création du support avec fusion au niveau de la hotend.

 

Systemic

Hello ,

utilises la broche Z+ (pin d2 de l'atmega) C'est sur cette broche que tu récupère le signal avec le capteur d'origine de la méga v1.

Modifié (le) par Murdock

Partager ce message


Lien à poster
Partager sur d’autres sites

Placer l'aimant ne va pas être évident sur la méga, d'autant que pour utiliser 100% de la surface de print la tête va souvent se rapprocher de l'aimant et donc risque de sortie accidentelle de la sonde. J'avais par le passé exploité ce genre de méthode et j'avais remplacé l'aimant par un electro aimant qui était activé par un relais via gcode.

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon alors la progression :

Il manque bien 50 cm de fils pour tout brancher correctement alors j'ai ajouté des dupond (pas de la même couleur mais tant pis). 

Je suis passé par le trou du endstop Y mais quand je ferai le montage correct, je passerai par le trou du câble chauffant du bed (plus près des fils qui vont au hotend) 

Je me suis pluggé sur le Pin 11 (servo) car c'est plus simple. 

J'ai mis à jour le firmware (je mettrais ça en default sur le GitHub pour tout le monde) et je le mettrai sur l'imprimante ce soir. 

Je vais fixer le sensor temporairement ce soir et faire mes tests. Si tout est bon, faudra voir pour faire un support sur la hotend. 

Sinon, pour l'activation avec l'aimant j'ai bien envie de le mettre en haut du cadre à gauche. Du coup l'activation se fera avec un X à 0 mais un Z à 200 par exemple. 

IMG_20180308_070626.jpg

IMG_20180308_070557.jpg

Modifié (le) par systemic

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Il y a 2 heures, systemic a dit :

Sinon, pour l'activation avec l'aimant j'ai bien envie de le mettre en haut du cadre à gauche. Du coup l'activation se fera avec un X à 0 mais un Z à 200 par exemple. 

À mon avis c'est impossible car pour atteindre le Z 200 il faut que tu ai fait un home Z avant et vu que ton Home Z se fait par le capteur il faut l'activer avant...

Je vois 2 solutions. Soit l'activer à la main soit mettre un servo moteur qui bascule soit le module d'activation soit le capteur

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon alors ça avance mais pas comme je veux.

Mon Z probe est bien vu quand je fait un M119. Mais il est vu "à l'envers". Donc quand je lance mon G29, ma hote end monte au lieu de descendre et fait des palpages dans le vide.

Si je monte la pin du sensor à la main, du coup il descend ...

Donc c'est pas loin mais j'ai un problème de configuration. 

 

Ce que j'ai mis dans mon fichier pin c'est :

#define Z_MIN_PROBE_PIN     11
#define Z_MAX_PIN          11 

Même si un des deux sert a rien.

 

et dans mon fichier conf :

#define Z_MIN_PROBE_ENDSTOP

 

J'ai essayé plusieurs trucs mais c'est pas encore concluant.
 

Modifié (le) par systemic

Partager ce message


Lien à poster
Partager sur d’autres sites

Juste pour le fun, voila mon bed en le faisant à la main en montant et descendant la pin du sensor:

 

Recv: Bilinear Leveling Grid:
Recv:       0      1      2      3      4
Recv:  0 +25.095 +35.090 +45.085 +55.080 +65.075
Recv:  1 +37.672 +32.265 +39.677 +29.682 +59.630
Recv:  2 +37.070 +47.065 +48.927 +58.922 +52.642
Recv:  3 +93.047 +83.053 +73.057 +72.633 +62.637
Recv:  4 +46.107 +56.102 +66.097 +76.093 +86.087

 

Le bed le plus pourri du monde avec 9 cm de variations :-)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon, je me répond à moi même :

#define Z_MIN_PROBE_ENDSTOP_INVERTING false

à la place de true :-)

 

Et hop ... ça marche. Encore quelques virgules mais c'est prometeur.

 

Recv: Bilinear Leveling Grid:
Recv:       0      1      2      3      4
Recv:  0 +4.780 +4.790 +4.775 +4.763 +4.728
Recv:  1 +4.797 +4.802 +4.808 +4.802 +4.720
Recv:  2 +4.815 +4.810 +4.797 +4.777 +4.715
Recv:  3 +4.845 +4.820 +4.830 +4.810 +4.710
Recv:  4 +4.873 +4.830 +4.828 +4.800 +4.730

 

Désolé pour la musique de la vidéo. 

Modifié (le) par systemic

Partager ce message


Lien à poster
Partager sur d’autres sites

Je vais tenter un support qui se clipse. Je vais faire une première impression pour voir ce que ça peut donner. Par contre, en mettant le capteur sur l'extérieur du cache de la hotend, on ne peut pas palper a moins de 3.5 cm du bord du plateau... C'est pas parfait mais ça ira bien pour un début. Faudra aussi que j'adapte les points de palpage une fois le capteur accroché.

 

Screen Shot 2018-03-09 at 16.41.38.png

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité

J'allais te proposer de le mettre dans le capot mais impossible avec le système d'activation. Sinon il faut regarder si tu peux arriver à le caser à coter du ventilo de pièce en imprimant l'une des modif disponible sur thingiverse

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×