Aller au contenu

Filament ABS

pid instable apres installation du mosquito hothend sur x1


ikizami

Messages recommandés

je n'arrete pas d'avoir des erreur depuis hier "heating failed; printer halted " depuis que j'ai installer un mosquito hothend avec la thermoresistance ht de slice et l'element chauffant d'origine . j'ai donc essayer de regler correctement mon pid mais ca n'arrete pas et pour encore plus m'enbrouiller j'ai jamais la meme valeurs mais encore ca reste assez stable autour de 5% sur 2 test fait a la suite mais alors si je change ma temperature ca fait juste plus aucun sens 

exemple en 200° ca donne : p13.22 i0.39 d48.47

               en 300°: p22.77 i2.48 d52.22

             et alors 400° : p3.48 i0.64 d4.7

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

https://support.sliceengineering.com/portal/en/kb/articles/faq

Citation

I bought a Slice High Temp Thermistor. Now What?

The thermistor (temperature sensor) on your printer is dialed in with your printer’s control board. When installing any new thermistor, including Slice’s High Temperature Thermistors, you will need to ensure the proper settings are input into your firmware, and should run a PID tune on your controller. The RT table for both of the Slice High Temperature Thermistors is available here. Duet3D natively supports both Slice High Temperature Thermistors. Marlin 2.0 now supports both of the Slice High Temperature Thermistor. Select Thermistor #67 in settings for the 450°C variant and #5 for the 300°C variant. We are constantly working with other firmware developers to include the Slice thermistors out of the box.

A tu modifié ton marlin ? car si l'on parle bien du capteur qui mesure jusqu'a 450°C alors cela me semble compliqué de l'utiliser avec la configuration de base ...

Lien vers le commentaire
Partager sur d’autres sites

à l’instant, ikizami a dit :

oui j'avais deja

tu a donc bien modifié un Configuration.h pour utiliser cette définition pour la thermistance ?

#define TEMP_SENSOR_0 67

Lien vers le commentaire
Partager sur d’autres sites

ok alors il te reste les pistes habituel, défaut de connexion, ventilateur qui souffle sur le capteur de température, capteur mal placé, ...

Edit a froid a tu une mesure de la température cohérente ?

Modifié (le) par PPAC
Lien vers le commentaire
Partager sur d’autres sites

Il faudrait etre sur que tu n'a pas de variation du a un mauvais raccordement comme un petit faux contacte ...

Sinon je n'ai jamais joué avec cela mais dans Configuration_Adv.h il y a :

Citation
/**
  * Thermal Protection provides additional protection to your printer from damage
  * and fire. Marlin always includes safe min and max temperature ranges which
  * protect against a broken or disconnected thermistor wire.
  *
  * The issue: If a thermistor falls out, it will report the much lower
  * temperature of the air in the room, and the the firmware will keep
  * the heater on.
  *
  * The solution: Once the temperature reaches the target, start observing.
  * If the temperature stays too far below the target (hysteresis) for too
  * long (period), the firmware will halt the machine as a safety precaution.
  *
  * If you get false positives for "Thermal Runaway", increase
  * THERMAL_PROTECTION_HYSTERESIS and/or THERMAL_PROTECTION_PERIOD
  */
  #if ENABLED(THERMAL_PROTECTION_HOTENDS)
  #define THERMAL_PROTECTION_PERIOD 40 // Seconds
  #define THERMAL_PROTECTION_HYSTERESIS 4 // Degrees Celsius
Lien vers le commentaire
Partager sur d’autres sites

j'y ai pensez aussi mais je préfère jouez avec ca qu'en dernier recours parce que le problème viens pas de la je pense (j'y ai pensez au début parce que j'avais installer le heater fourni par slice mais il fait que 50w comparer a celui de la sidewinder qui est en 64)

Lien vers le commentaire
Partager sur d’autres sites

ducoup j'ai essayer de lancer 2 m303 un en s400 c20 et un autre en s200 c 20 et aucun soucis apparent je lance donc un benchy voir si ca tien et la je sais pas si c'est mieux ou pire mais voila 

je precise que je suis bien en pid j'ai verifier vais essayer de modifier un peu le pid_k1 voir un peu ce que ca donne mais la j'commence a etre perdu 

temp.PNG

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

Déjà moi ce qui m'étonne ce sont tes valeur a froid a froid tu as non seulement un variation assez importante mais en plus bien différente que celle du Bed ce qui n'a pas de sens a croire que ta sonde renvoie une mauvaise valeur ou alors la buse avait été en chauffe et était pas redescendu a sont niveau le plus froid.

Pour la cartouche chauffante 50w cela pose pas de soucis en tout cas pour ma part même une cartouche 40w va très bien et met pas plus de temps que le 64w d'origine avec mon boc cuivre. d'ailleur les cartouche de 64w consomme plus que ne support a pick les nappe de la X1.

L'autre soucis possible serait lié a ton mosfet de chauffe de la buse qui commence a déconné sur la GenL sa m'etait arrivé du jour au lendemain moi depuis que je tourne sur une Sgenl j'ai plus 1 ° de variation sur buse ou bed.

Lien vers le commentaire
Partager sur d’autres sites

Salut,

  Déjà les valeurs de PID se calculent toujours autour d'un point de fonctionnement. Forcement tu n'auras pas les mêmes valeur à 200 ou 400°C. Donc règle le PID avec comme valeur cible 250°C si tu imprimes principalement du PLA/ABS/PETG.

Pour faire simple une régulation est un compromis entre vitesse et stabilité.

Donc essaie de diminuer progressivement le terme "P" jusqu'a ce que les fluctuations s'arrêtent. 

  • Merci ! 1
Lien vers le commentaire
Partager sur d’autres sites

tout etait  bien a froid pas de soucis la dessus et je suis passez sur la 64 parceque si j'etait rester sur la 50 j'aurais du augmentez le thermal protection period et j'etait pas super chaud a faire ca en vrai apres j'ai pense a l'eventualite de changer de carte mere mais j'etait pas parti la dessus tout de suite donc pas avant le moi prochain en attendant j'ai essayer de suivre ca suis en train de l'installer la 

edit : edit j'ai essayer j'ai des temperature stable mais a -20 donc bon ca marche mais ca marche pas je vais essayer le pt100 que j'ai sous le coude aussi ce weekend voir si vraiment ca vien pas de la thermistance mais sinon ouai plus qu'a changer la carte mere 

 

 

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

Le 16/06/2021 at 11:45, Rlv a dit :

Salut,

  Déjà les valeurs de PID se calculent toujours autour d'un point de fonctionnement. Forcement tu n'auras pas les mêmes valeur à 200 ou 400°C. Donc règle le PID avec comme valeur cible 250°C si tu imprimes principalement du PLA/ABS/PETG.

Pour faire simple une régulation est un compromis entre vitesse et stabilité.

Donc essaie de diminuer progressivement le terme "P" jusqu'a ce que les fluctuations s'arrêtent. 

j'avais bien compris ca mais c'etait d'avoir des difference aussi extreme qui ma choquer surtout que ca devient tres vite instable mais pas de sopucis je vais essayer ca aussi 

Lien vers le commentaire
Partager sur d’autres sites

@ikizami Attend tu utilise une PT100 ? si je me plante pas la PT100 n'est pas compatible avec les GenL sa risque pas de fonctionné comme il faut, et même sur certaine CM compatible demande un interface d'adaptation. 

Lien vers le commentaire
Partager sur d’autres sites

Il y a 15 heures, ikizami a dit :

ducoup pense que vais recup la mks gen l pour faire joujou avec des stepper (plus tard la c'etait pas le plan ) et vais passez sur la mks sgen l

Si tu souhaite passer du coup sur la SgenL Prend la V2 pas la V1 j'ai fournit un tuto dans mon topic review en signature expliquant le passage de SgenL V2, si cela peu aider mais j'ai conçu de marlin que pour la Genius actuellement mais si tu as besoin je pourrais facilement faire un dérivé pour la X1 ou te fournir mes sources de la Genius pour te faire ton marlin. ou Utilisé le Molise etc . 

Lien vers le commentaire
Partager sur d’autres sites

carrement ouai j'ai commandez la v2 ducoup (j'en connais un qui va encore finir son moi avec des pates et de l'eau ) mais toutes aide est bienvenue honnetement parceque j'etait deja entrain de me faire des noeux au cerveaux pour savoir comment editez ma version de marlin 

j'ai lu une parti de tes topics et tu a fait tous ce que j'envisage de faire en fait changement de plateaux mise en place d'un caisson plus tes topics serieux beaux boulot j'ai vue que tu etait passez sur des tmc 2209 et serieux je me suis pas encore penchez sur le sujet des driver stepper je doit les changer aussi pour ton firmware ou pas ? 

edit: et la que j'y pense je vais aussi surement rajouter un meilleur capteur de fin de filament plus tard un de ceux qui detecte aussi les jam et re-utiliser celui de base pour allumer une led ou une notification audio dans mon bureaux parceque sur des gros print je passe mon temp a faire de allez retour de peur que le filament arrive au bout 

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

Il y a 15 heures, ikizami a dit :

carrement ouai j'ai commandez la v2 ducoup (j'en connais un qui va encore finir son moi avec des pates et de l'eau ) mais toutes aide est bienvenue honnetement parceque j'etait deja entrain de me faire des noeux au cerveaux pour savoir comment editez ma version de marlin 

j'ai lu une parti de tes topics et tu a fait tous ce que j'envisage de faire en fait changement de plateaux mise en place d'un caisson plus tes topics serieux beaux boulot j'ai vue que tu etait passez sur des tmc 2209 et serieux je me suis pas encore penchez sur le sujet des driver stepper je doit les changer aussi pour ton firmware ou pas ? 

edit: et la que j'y pense je vais aussi surement rajouter un meilleur capteur de fin de filament plus tard un de ceux qui detecte aussi les jam et re-utiliser celui de base pour allumer une led ou une notification audio dans mon bureaux parceque sur des gros print je passe mon temp a faire de allez retour de peur que le filament arrive au bout 

Bien mon Firmware pour la SGenl V2 est pour la Genius il y a des petites adaptation sur les dimensions du bed donc si tu souhaite utiliser les AT2100 d'origine ou d'autre driver comme des 2208 c'est faisable, mais les AT2100 ne support pas l'uart donc faudra définir les driver en standalone, modifié le sens de rotation des moteur par rapport 2209 et le reglage des vref ne ce fera que part ajustement du potentiomètre impossible de le réglé via le firmware.

Même si je ne l'ai pas activé dans mon marlin et configurer sur la la SGenl v2 sur ma Genius tu peux aussi fait du senssorless homing avec les 2209 c'est à voir.

Les 2209 c'est d'excellent driver je l'ai est installé au départ surtout pour fiabiliser l'électronique, et je dois dire que je l'ai trouve plus silencieux et fluide. Mais les 2100 si ils sont parfaitement fonctionnel font le job.

Tu me diras ce que tu souhaite mettre en place et je t'aiderais a ce moment la 😉

  • J'aime 1
Lien vers le commentaire
Partager sur d’autres sites

j'etait entrain de lire un peu plus en details ton topic justement mais je pense passez sur les 2209 ducoup vue que la mks sgen arrivera que le 29 d'ici la je pourrais les commander 

edit: sans le sensorless homing j'etait pas parti sur le fait d'upgrade toute mon imprimante d'un coup et ducoup sui perdu a ce stade la ca a ete trop vite pour moi la j'comprend plus tout bien donc on va limiter au max les galere possible

Modifié (le) par ikizami
Lien vers le commentaire
Partager sur d’autres sites

Je comprend @ikizami

Le Senssorless homing pour faire simple demande d'indique au marlin de valeur pour réglé la sensibilité, en gros quand ton moteur force  sur un axe il fait un appel de courant plus important, donc on indique une valeur qui ne doit pas être trop faible pour que cela ne détecte pas une position de homing au moindre grain de sable mais qu'il indique le home de l'axe quand on arrive en buté et que sa commence a forcer.

Mais on a des capteur inductif qui sont pas mauvais j'ai pris le parti de les conservé du coup. 😉

Pour les 2209 je te recommande de prend des MKS sur certain modèle d'autre marque il faut faire gaffe car le uart ou sensoless peux demandé des modif.

Lien vers le commentaire
Partager sur d’autres sites

il y a une heure, ikizami a dit :

https://www.amazon.fr/gp/product/B0854DQCQ8/ref=ox_sc_act_title_1?smid=A31ODO8OD3XQQH&psc=1 ceux la c'est bon ? je sais que je pourrais les trouver moins cher mais j'aimerais bien recuperer mon imprimante avant la fin de l'ete vue que j'ai que celle la

C'est bien des MKS on dirait, TMC2209 V1 moi j'ai des V2 et mes V2 on 2 pin de plus, mais de ce que je vois ils ont bien le UART.

 

après petite recherche les V1 ici avec leur 2 pins de moins ne permettent pas l'usage du sensorless homing sans modification. Pour le reste ils font le job.

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...