Aller au contenu

Filament ABS

bltouch auto level


ZiRaTeX

Messages recommandés

bonjour j ai un problème avec mon bltouch. je l ai installer avec le firmware marlin et il fonctionne le seul bémol c est quand je lance le print pour tester la premier couche il fait bien l auto level au début mais quand il va pour faire la premier couche la buse monte je vous laisse une vidéo  https://www.casimages.com/f/q6wBaOjqqWb merci de votre aider.

IMG_20210803_153417.thumb.jpg.3997b7b7fefebb7717ae12cef47bc97d.jpgIMG_20210803_153430.thumb.jpg.fc9ccec95406f720d468befa7314b7a5.jpg

Lien vers le commentaire
Partager sur d’autres sites

Il y a 1 heure, hyoti a dit :

Bonjour,

Cela a l'air d'être sur les différents endroits du plateau.

Est- ce que la valeur du Z-offset est bonne, l'as tu vérifiée ?

🙂

j ai fait auto level et après j ai régler le z-offset. au final sa fait comme si je n avait pas de bltouch

Modifié (le) par ZiRaTeX
Lien vers le commentaire
Partager sur d’autres sites

il y a 9 minutes, RFN_31 a dit :

Pour moi, il faut plutôt faire l'inverse : régler le z-offset puis faire le mesh du plateau.

Je suis du même avis, le BLtouch sert aussi de Z-stop. (Homing)

Après avoir fait tourner involontairement une molette du plateau en le manipulant, je n'arrivais plus à régler le Z-offset.

Nouvelle valeur offset puis move Z à 0 pour réglage feuille de papier jusqu'à plusieurs 1/10.

Cela faisait le YOYO.

Le pb s'est réglé tout seul (enfin presque) juste un peu long avec la procédure suivante.

  • nouvelle valeur offset, (sauvegarde),
  • homing ou au moins home Z
  • puis move Z ( vers 0 ) et feuille papier qui gratouille. et cyclage procédure  jusqu'au bon offset et gratouille.

L'auto leveling après quand le z0 et le offset sont propres.

Je ne sais pas pourquoi, c'est comme si lorsque l'on change la valeur de l'un cela change l'autre partiellement. (il doit y avoir une bonne raison)

🙂

Lien vers le commentaire
Partager sur d’autres sites

Il y a 21 heures, hyoti a dit :

Je suis du même avis, le BLtouch sert aussi de Z-stop. (Homing)

Après avoir fait tourner involontairement une molette du plateau en le manipulant, je n'arrivais plus à régler le Z-offset.

Nouvelle valeur offset puis move Z à 0 pour réglage feuille de papier jusqu'à plusieurs 1/10.

Cela faisait le YOYO.

Le pb s'est réglé tout seul (enfin presque) juste un peu long avec la procédure suivante.

  • nouvelle valeur offset, (sauvegarde),
  • homing ou au moins home Z
  • puis move Z ( vers 0 ) et feuille papier qui gratouille. et cyclage procédure  jusqu'au bon offset et gratouille.

L'auto leveling après quand le z0 et le offset sont propres.

Je ne sais pas pourquoi, c'est comme si lorsque l'on change la valeur de l'un cela change l'autre partiellement. (il doit y avoir une bonne raison)

🙂

comment fait on pour sauvegardé le z-off set car pour ma part je fait le z-off set puis je fait l auto level après. 

Lien vers le commentaire
Partager sur d’autres sites

voici mon gcode du début 

G28 ; home

G29;Probe time

M117 Purge extruder

G92 E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

G1 X2 Y20 Z0.3 F5000.0 ; move to start-line position

G1 X2 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X2 Y200.0 Z0.4 F5000.0 ; move to side a little

G1 X2 Y20 Z0.4 F1500.0 E30 ; draw 2nd line

G92 E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

 

 

Il y a 21 heures, Idealnight a dit :

dis nous comment tu as procédé ? pour faire le mesh et surtout le sauvegarder et enfin le déclaré dans le gcode ?

Lien vers le commentaire
Partager sur d’autres sites

donc là ton mesh n'est pas en mémoire, il se fait a chaque impression (G29).

Pour le z-offset une fois réglé dans le menu il faut faire SAVE.

Edit: et pour faire un z-offset il faut bien penser mettre en chauffe d'impression buse et bed, puis déplacer l'axe Z en position 0 et enfin on va régler le z-offset)

Modifié (le) par Idealnight
Lien vers le commentaire
Partager sur d’autres sites

il y a 30 minutes, Idealnight a dit :

donc là ton mesh n'est pas en mémoire, il se fait a chaque impression (G29).

Pour le z-offset une fois réglé dans le menu il faut faire SAVE.

Edit: et pour faire un z-offset il faut bien penser mettre en chauffe d'impression buse et bed, puis déplacer l'axe Z en position 0 et enfin on va régler le z-offset)

je n est pas de save.

IMG_20210804_164311.jpg

Lien vers le commentaire
Partager sur d’autres sites

Faudrait un "pro" sidewinder peut-être que tout est save par défaut une fois le réglage fait (et du coup si l'auto level l'est aussi alors ce n'est pas G29 qu'il faudrait dans ton gcode mais un M420 S pour rappeler le mesh).

Donc attends une réponse de quelqu'un qui connait ta machine (par exemple @Savate 🙂 )

Lien vers le commentaire
Partager sur d’autres sites

@ZiRaTeXça dépend du firmware que tu as flashé (mais je pense que la sauvegarde doit être automatique sur ce firmware),

Par sécurité tu peux, après avoir effectué le Z-offset, lancer une commande M500 à partir de cura ou octoprint ou proterface -> le M500 sauvegarde les valeurs courantes dans l'eeprom.

Ensuite tu peux lancer une commande G29  (cura ou octoprint ou pronterface)

Suivie d'une commande M500 quand la Palpation du plateau est terminée.

Ensuite comme le dis @Idealnight il faut remplacer le G29 du GCode de démarrage par un M420 (qui récupère le bed mesh de la sauvegarde par défaut) 

ça évite de se taper la palpation du plateau à chaque impression. 

  • +1 1
Lien vers le commentaire
Partager sur d’autres sites

j ai réinstaller le firmware puis j ai regler le z off set et après l auto level mais pas de changement la buse monte tout seul a certain de endroit bed comme sur la vidéo que j ai envoyer dans mon premier message.je suis désole pour le manque d aide que je peux vous fournir me je suis novice. 

Lien vers le commentaire
Partager sur d’autres sites

  • 3 weeks later...

Salut @ZiRaTeX ton problème est il résolue ? j'avais pas vue ce post honte a moi 😄.

De ce que j'ai vue sur les poste précédent ton firmware d'écran est un firmware MKS modifié version Waggster ou Gueroloco, déjà la sauvegarde du Z-offset est automatique chaque mouvement de réglages du Z-offset lance un M500 directement après. Pour la procédure en effet il est recommander d'effectué le Z-offset et après un ABL. (Ceci est surtout pour répondre a des interrogations que pouvait avoir certain lecteur)

ton BLT est bien cablé sinon ni le Z offset ni l'ABL ne serait realisable.

Pour la parti Start G-code, il y a 3 facon de faire :

- Permiere façon effectué un G29 après le G28 pour relancer un ABL avant chaque impression ce qui remesure et active les valeur de Bed Leveling. Méthode très utilisé dans le passé.

- Deuxième méthode comme la indiqué @Savate et @Idealnight utilisation de la commande M420 ou M420 S1 a la place du G29, dans ce cas on indique l'activation du bed leveling qui restaure les valeur précédente après le G28 et évite de relancé un ABL a chaque print. Nécessaire sur certain Firmware.

- La Troisème méthode est d'utiliser un firmware qui active la fonction Restore Bed Leveling after G28 dans le marlin, dans ce cas tu n'as pas a ajouter de G29 ou M420 après le un G28 car ici le Marlin le fera automatiquement pour toi.

La je vous est expliquer les possibilité ou réglage nécessaire, mais il y a un élément que l'on a pas évoquer Quels firmware utilise marlin a tu installé sur ton imprimante. Je suspect un soucis possible avec ce dernier. L'utilisation d'un autre firmware comme le mien le digant ou le molise pourrait résoudre ton soucis.

Modifié (le) par MrMagounet
Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
×
×
  • Créer...