Aller au contenu

Filament ABS

Wrmaeleun

Configuration simplifiée de nos firmwares

Messages recommandés

Salut la communauté !!!

Je me permets de créer ce sujet car j'ai trouvé ces infos sur un autre post (les upgrades de DuDum) et l'information me semble assez intéressante pour faire l'objet d'un sujet à part entière...

Constatant la multitude de configurations différentes que nous utilisons sur nos D200 (plateau chauffant, Direct Drive, palpeur, DiscoLED...), Dagoma nous propose (en version bêta) des outils qui pourraient bien nous simplifier la vie.

A chaque configuration, son firmware :

Le tutoriel : DagomaDoctor et nouveaux Firmwares

Le générateur de Firmware : http://dist.dagoma.fr/Marlin-Firmwares/D200_Melzi

Le logiciel de transfert sur la Melzi (LINUX / MAC / WINDOWS) : DagomaDoctor

Tout ceci reste bien évidemment à tester, mais les premiers retours semblent prometteurs. 

Modifié (le) par Wrmaeleun
Modification lien
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir, j'ai testé cet après midi le soft avec le firmware Discoled. L'impression fonctionne sans soucis via la carte sd mais impossible de piloter l'imprimante par Octoprint ou 3dPrinterOs. Pour les fameuses goutellettes je ne sais pas encore si le pb est résolu.

Envoyé de mon SM-G920F en utilisant Tapatalk

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@Wrmaeleun J'ai juste testé via Octo et 3dPrinter par usb sur mon PI et dans les deux cas il y a un soucis lors de la phase d'initialisation entre le soft et l'imprimante.

Dès que je termine mon impression je vais tester en direct avec Cura.

Modifié (le) par CaliBx

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je n'ai pas réussi à faire fonctionner l'imprimante avec Cura.

Côté Octoprint, j'ai un timeout étrange ... (en mode reset ou pas d'ailleurs) :

Connecting to: /dev/ttyUSB0
Changing monitoring state from 'Offline' to 'Opening serial port'
Connected to: Serial<id=0x6e948bf0, open=True>(port='/dev/ttyUSB0', baudrate=250000, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from 'Opening serial port' to 'Connecting'
Send: N0 M110 N0*125
Recv: start
Send: N0 M110 N0*125
Recv: echo:Marlin 1.1.0-RC6
Recv: echo: Last Updated: 2016-04-24 12:00 | Author: Dagoma.Fr
Recv: Compiled: Aug 22 2016
Recv: echo: Free Memory: 11704  PlannerBufferBytes: 1232
Recv: echo:V23 stored settings retrieved (396 bytes)
Recv: echo:Steps per unit:
Recv: echo:  M92 X80.00 Y80.00 Z2560.00 E98.00
Recv: echo:Maximum feedrates (mm/s):
Recv: echo:  M203 X500.00 Y500.00 Z4.00 E25.00
Recv: echo:Maximum Acceleration (mm/s2):
Recv: echo:  M201 X9000 Y3000 Z100 E10000
Recv: echo:Accelerations: P=printing, R=retract and T=travel
Recv: echo:  M204 P3000.00 R3000.00 T3000.00
Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
Recv: echo:  M205 S0.00 T0.00 B20000 X20.00 Z0.40 E5.00
Recv: echo:Home offset (mm):
Recv: echo:  M206 X0.00 Y0.00 Z0.00
Recv: echo:PID settings:
Recv: echo:  M301 P126.27 I24.08 D165.51 C100.00 L20
Recv: echo:Filament settings: Disabled
Recv: echo:  M200 D3.00
Recv: echo:  M200 D0
Recv: echo:Z-Probe Offset (mm):
Recv: echo:  M851 Z-0.70
Recv: echo:SD init fail
Recv: OK
There was a timeout while trying to connect to the printer
Changing monitoring state from 'Connecting' to 'Offline'
Connection closed, closing down monitor

 A suivre ...

Partager ce message


Lien à poster
Partager sur d’autres sites

P'tite question @CaliBx , as-tu déplacer ton cavalier en mode USB comme sur cette photo ?

Screen-Shot-2015-04-25-at-18.27.25.jpg

Si ce jumper (celui de droite sur la photo) est sur Vreg => Lecture sur la carte SD , si il est sur Vusb => Lecture en mode usb ... et donc , si comme je le soupçonne , tu n'as pas mis ce jumper dans la bonne position , ta dago ne communique pas par usb et attend une carte sd. ^_^

Attention , ne pas mettre le jumper auto-reset sur on , c'est une photo venant de Dagoma expliquant une autre manoeuvre !

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est super marrant en me balandant et en choisisant différentes options on arrive à trouver des firmwares pour du dual extruder :)

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, bdevis a dit :

C'est super marrant en me balandant et en choisisant différentes options on arrive à trouver des firmwares pour du dual extruder :)

Oui sauf que la Melzi ne dispose que d'un connecteur hotend. Si tu veux le faire il te faudra mettre 2 Melzi en parallèle.

Partager ce message


Lien à poster
Partager sur d’autres sites

et ? dual extruder ne veut pas dire 2 hotend :)

Regarde la petite famille de la chimera.

Partager ce message


Lien à poster
Partager sur d’autres sites

OK pour la chimera.

Sauf que encore une fois la Melzi ne dispose pas de 2eme connecteur pour le 2eme extrudeur. De plus comment pouvoir utiliser 2 matière différente si tu ne peux contrôler la température de chacune des matière.

La solution reste la mise en // de 2 Melzi

Partager ce message


Lien à poster
Partager sur d’autres sites

@Nz0 pas mieux en USB, toujours le timeout.

Je croyais que la différence entre le mode "usb" et "régulé" était la source d'alimentation de la carte (et donc impossible d'imprimer en usb).

Dans tous les cas ni l'un ni l'autre ne fonctionne alors qu'avant le changement de firmware tout était bon sous Octoprint et 3dPrinterOs.

Je vais patiemment attendre une nouvelle version du firmware comme c'est parti ....

Partager ce message


Lien à poster
Partager sur d’autres sites

@CaliBx , même si tu es sur Vusb , tu dois laisser ton alimentation pour pouvoir contrôler les moteurs (12volts)... l'usb sert juste pour la communication et l'alim 5 volts interne de la melzi (si le jumper est sur Vreg , le 5 volts sera pris sur le bloc d'alim)

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon je poursuis mes tests et avec le firmware de base (sans discoled) pas de souci ! Octoprint prend bien le contrôle de l'imprimante et tout re-fonctionne correctement 

Reflash de la version avec l'écran : re timeout

=> le firmware de l'écran casse le pilotage par USB

@Nz0 par contre je ne comprends pas, en régulation je peux aussi la piloter en USB via Octo

Modifié (le) par CaliBx

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, bdevis a dit :

C'est super marrant en me balandant et en choisisant différentes options on arrive à trouver des firmwares pour du dual extruder :)

C'est le firmware pour l'explorer 350

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 15 heures, Nz0 a dit :

@CaliBx , même si tu es sur Vusb , tu dois laisser ton alimentation pour pouvoir contrôler les moteurs (12volts)... l'usb sert juste pour la communication et l'alim 5 volts interne de la melzi (si le jumper est sur Vreg , le 5 volts sera pris sur le bloc d'alim)

en Vusb le 5V vient de l'USB, ça permet de balancer le firm carte démontée.

en Vreg le 5V vient du 7805 alimenter par le 12V

 

C'est mieux de transférer le firm en Vusb, alim débranchée, pour éviter les problèmes de communication dues aux bizarreries de l'électronique. 

 

La machine imprime avec la carte SD que l'on soit en Vreg ou en Vusb , alim et cable usb branché  .(ca doit être pareil en impression usb)

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, plexy a dit :

C'est mieux de transférer le firm en Vusb, alim débranchée, pour éviter les problèmes de communication dues aux bizarreries de l'électronique.

Tout à fait d'accord

 

il y a 5 minutes, plexy a dit :

La machine imprime avec la carte SD que l'on soit en Vreg ou en Vusb , alim et cable usb branché  .(ca doit être pareil en impression usb)

N'imprimant pas en usb (du moins pour le moment) , j'avais fait un test sur Vusb avec une sd (mais sans le câble usb de branché) => l'imprimante ne lit pas le gcode sur la sd mais son ventilo tourne

Je viens donc d'apprendre quelque chose et t'en remercie @plexy !

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut à tous,

J'ai un p'tit problème avec le générateur de firmware qui n'affiche pas le bouton de chargement du fichier généré après les choix dans la colonne Résultat.

J'ai essayé sur 2 navigateurs (Safari OSX, et Firefox OSX)

Avez vous ce pb de votre coté avant que je ne face un retour à Dagoma ?

Capture d’écran 2016-08-30 à 22.15.26.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

@Picaboubx : c'est normal, tu n'as pas défini tous les critères qui permettent de sélectionner précisément ton firmware. Dans la colonne "Critères restants", tu dois cliquer, pour chacune des lignes restantes, sur le choix qui correspond à ta config. Une fois tous les critères définis, tu pourras télécharger le firmware.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×