Aller au contenu

Filament ABS

LOLO710

CR10 flashage ou pas?

Messages recommandés

Ok fais le sanguino.

Pour les réglages (!important) : http://www.cr10.fr/le-guide-malin-de-marlin/

Mais sinon il y a tjrs mon lien vers le firmware TH3D.. Tu n'auras qu'à indiquer que tu as une CR10 + langue en FR et il s'occupe de tout le reste.

Modifié (le) par ShagoY
  • Merci ! 1

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Bonjour, je suis en plein flashage de ma cr10 avec le tuto  http://www.cr10.fr/ameliorations/marlin/

je suis a l’étape 4  et de la 3eme ligne:

3.Copiez les « fichiers exemples » de la CR10 (…\Marlin\example_configurations\Creality\CR-10) dans le dossier le Marlin (…\Marlin) et remplacez les fichiers existant.

si quelqu'un pouvais m’éclairé comment appliqué cette ligne.

merci d'avance 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour shagoy,

j' ai trouvé je fais un copier collé, une fois que je suis dans la configuration.h je m' aperçois que ça a modifié les paramètres et les ajustes pour les cr10.

je suis dans le paramétrage du firmware j' en ai mal a la tête, je sais pas si je modifie les paramètres 

ceux-ci sont ceux du tuto  

// Stock CR-10 Hotend fan 100%
#define DEFAULT_Kp 17.42
#define DEFAULT_Ki 1.27
#define DEFAULT_Kd 59.9

et ceux la du firmware

// Stock CR-10 tuned for 70C
  #define  DEFAULT_Kp 22.57
  #define  DEFAULT_Ki 1.72
  #define  DEFAULT_Kd 73.96

Partager ce message


Lien à poster
Partager sur d’autres sites

Là c'est les paramètres du "PID" (gestion de chauffe du hotend), ce sont des valeurs que tu pourras modifier par la suite en lancant une commande qui trouveras les valeurs intrasec de ton imprimante. De plus, il y a peu de différence entre les deux.. Prends les premiers, il n'y aura aucune incidence.

N'oublie pas que tu peux prendre le firmware TH3D, hein ;)

Modifié (le) par ShagoY

Partager ce message


Lien à poster
Partager sur d’autres sites

Reste que tu aurais pu juste faire les modifications à partir de l’étape "Notice d’utilisation du tuto:" de http://www.cr10.fr/le-guide-malin-de-marlin/

Pour te démystifier la chose, dis toi juste que tu es entrain de mettre les valeurs de ta CR10 dans le firmware Marlin car celui-ci ne peut forcement pas s'adapter automatiquement à toutes les imprimantes.

Modifié (le) par ShagoY

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est bon les gars tout c'est bien passé  j'ai marlin sur ma cr10 et en français avec plein de réglages, il me reste plus qu'a attendre que les pièces pour mon hotend arrive pour pouvoir réimprimé.

juste une question que je me pose, si je veut modifie mon firmware j'aurais plus besoin de retouche au cavalier a l’intérieur  du boitier, simplement a branche le cordon usb ?5acba7a1b446c_Picture10.thumb.jpg.f906ad30a75c3102f2929de0ab3578e0.jpg5acba795ed9ef_Picture11.thumb.jpg.2d54208357dd06b3c2401c14839ad074.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, LOLO710 a dit :

juste une question que je me pose, si je veut modifie mon firmware j'aurais plus besoin de retouche au cavalier a l’intérieur  du boitier, simplement a branche le cordon usb ?

Exact. Par USB ou si tu as octoprint via le bon plugin :)

Partager ce message


Lien à poster
Partager sur d’autres sites

bonsoir a  tous ,

je viens de flasher en 1.1.9 ma cr-10 , apres plusieurs jours de recherche et de manip , ma machine est de nouveau fonctionnelle, ,,, sauf que , je ne peux plus imprimer avec la carte sd.

a chaque demarrage je vois la tete partir vers les Z=400 ??? , au lieu de filer vers le centre du bed ??

J'ai fait un changement de buse --> V6 e3d + Titan + 2 ventilos. + flashage 1.1.9 avec la carte arduino uno Rev3.

En mode usb , ca marche comme avant , mais c'est l'impression avec la carte SD qui me pose soucis ??

Je ne sais pas si c'est dans le marlin le pb ? 

Une idée SVP ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 19/11/2018 at 21:38, ours_brun83 a dit :

bonsoir a  tous ,

je viens de flasher en 1.1.9 ma cr-10 , apres plusieurs jours de recherche et de manip , ma machine est de nouveau fonctionnelle, ,,, sauf que , je ne peux plus imprimer avec la carte sd.

a chaque demarrage je vois la tete partir vers les Z=400 ??? , au lieu de filer vers le centre du bed ??

J'ai fait un changement de buse --> V6 e3d + Titan + 2 ventilos. + flashage 1.1.9 avec la carte arduino uno Rev3.

En mode usb , ca marche comme avant , mais c'est l'impression avec la carte SD qui me pose soucis ??

Je ne sais pas si c'est dans le marlin le pb ? 

Une idée SVP ?

Salut,

As-tu vérifié ces paramètres dans Marlin :

1332 | //#define SDSUPPORT

Pour pouvoir imprimer depuis une carte SD, vous devez absolument activer cette option.

1332 | #define SDSUPPORT

Partager ce message


Lien à poster
Partager sur d’autres sites

Personnellement,

J'ai d'abord installer celui de TH3D basé sur Marlin 1.1.9. Tout semble fonctionnel sauf qu'avec un fichier GCODE de référence fournit avec la CR10, j'ai de gros soucis de sous extrusion.

J'ai ensuite tenter un marlin 1.1.9 de base en suivant ce tuto http://www.cr10.fr/le-guide-malin-de-marlin/ -> échec complet rein ne fonctionne (les moteurs ne réagissent pas, l'ordre pour définir la température du lit ne fonctionne pas, voir freeze ...

Après ça j'ai voulu revenir au firmware d'origine : https://github.com/pressreset/Original-CR10-Marlin-Firmware-Source ou celui fournis par Creality : https://fr.creality3d.cn/download/firmware_c0001 -> impossible de compiler malgré qq corrections de variable mal nommées ...

Finalement, je suis revenir au firmware fournis par TH3D mais en essayant de reprendre les valeurs des firmwares d'origines (notamment pour la vitesse de rétractation vu mes pblms de sous extrusion) , c'est mieux j'ai toujours de la sous-extrusion ...

Modifié (le) par slobberbone

Partager ce message


Lien à poster
Partager sur d’autres sites

@rmlc460 En effet, je pensais naïvement que tout irait sans soucis ... Cependant, on a accès à pleins de fonctionnalités intéressantes, bon on ne peut plus imprimer ... lol

Je ne doute pas de finir par avoir la bonne configuration ...

Partager ce message


Lien à poster
Partager sur d’autres sites

Bon alors, pour être tout à fais honnête, j'ai eu juste avant de changer le firmware (le but est de mettre mon BLTouch) un soucis d'adhésion et ça a complétement foutu la grouille sur un print (d'où le BLTouch ...)  tout était bouché ect ....

Et comme du coup en enlevant la masse de PLA qui s'est accumulé autour de la buse, j'ai arraché la sond thermique, les cables du ventilateurs etc ... j'ai tout remplacé pour mettre un ventilo silencieux, mettre des connectiques pour tous les cables arrivant à la tête etc ... quitte à faire une passe, j'ai ouvert le boitier et j'ai passé mis un bootloader et passer le firmware Marlin 1.1.9 (mod TH3D) , bref tout d'un coup et c'était une erreur.

Tout ça pour dire que je viens de trouver ceci

Et si ça se trouve le PTFE n'est plus bien enfoncé ... (vu ce qui m'est arrivé) et que le firmware n'y est pour rien ... (la modif de TH3D pas le firmware Marlin direct, car impossible de le faire fonctionner)

J'ai tout démonté, retiré encore du PLA de la couleur (noire) quand ca a débordé de partout alors que j'utilise du filament Orange depuis 2 semaines que je galère ... et là remis le PTFE en espérant qu'il aille bien jusqu'au bout comme le montre le schéma dans le lien ci-dessus :

Si c'est là ma source du problème, clairement le Firmware TH3D avec retractation à 500 mm/s et non 1000 mm/s (et j'en ai profité pour reprendre les PID du firmwware d'origine (plus haut).

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...