Aller au contenu

Filament ABS

Nibb31

Présentation et premiers problèmes

Messages recommandés

Bonjour,

Je suis tout nouveau dans le monde de l'impression 3D avec une Anet A8 toute neuve installée dans mon garage. Je suis un gros geek et assez bricoleur, donc une machine évolutive et en kit semblait parfait pour moi, même si je reconnais que ce n'est pas pour tout le monde.

J'ai réussi le montage et après quelques ajustements sur l'axe Z, les pièces produites sont tout à fait correctes. J'ai d'ailleurs été content de voir que les problèmes de sécurité avec le connecteur du plateau chauffant ont été résolus dans les nouveaux kits et qu'il n'y a plus de risque d'incendie de ce coté là.

Malheureusement, après 3 impressions satisfaisantes, mon A8 est HS. J'ai du trop serrer l'écrou de la tête d'impression lors du montage et le heatbreak s'est cassé. Une tête de remplacement est en route avec deux heatbreaks et deux buses de rechange...

En attendant la nouvelle pièce, j'ai voulu essayer d'installer Octopi, et là, j'ai un souci. Il m'est impossible de faire reconnaître la prise USB de la carte Anet. J'ai essayé de le connectet avec plusieurs cables USB, sur le RPi et sur mon PC (qui est en linux) et la commande 'lsusb' n'affiche rien. C'est comme s'il n'y avait rien de connecté. J'en conclus que soit le port USB de la carte Anet 1.0 est défectueux, soit il y a un bug dans le firmware. Je suis assez débrouillard en Linux et en Raspberry, mais je n'y connais pas grand chose en Arduino.

Je me demandais donc s'il était possible de flasher un firmware Marlin sur la carte Anet 1.0 sans passer par l'USB qui n'est pas reconnu. Peut-être en rajoutant un fichier sur la carte SD ou quelque chose comme ça...

Modifié (le) par Nibb31

Partager ce message


Lien à poster
Partager sur d’autres sites

Salut.

Pas de bol si le port USB est mort côté carte.

Pour le flash, regarde le paragraphe 3.4 de ce document :

https://docs.google.com/document/d/1Zc4npRdrvlcc0-hxNev2K2siTEBIyJAHCGOxF5VJERY/edit

Par contre, même avec un Marlin dessus, si ton port USB est mort, tu ne pourras pas piloter ton imprimante via OctoPrint.

Partager ce message


Lien à poster
Partager sur d’autres sites
youtube drone débutant

Merci pour les réponses,

Perdu pour perdu, je voudrais tenter de flasher pour voir si ce n'est pas un problème de firmware. Toutes les autres fonctions de la carte ont l'air de marcher. Je vais essayer de démonter la carte pour vérifier les soudures et les pistes. La qualité de la carte Anet n'a pas l'air d'être géniale (radiateurs collés de travers, connecteurs qui bougent...)

J'ai essayé de modifier le Baudrate dans Octopi et sur l'Anet, mais sans succès. Dans la liste "Port Série" d'Octoprint, je n'ai que "Auto", ce qui paraît logique puisque l'OS ne voit rien connecté en USB quand je tape "lsusb" en ligne de commande.

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour la connexion via le PC, je suis sous Windows, j'ai dû installer un driver pour que l'imprimante soit reconnue. Le driver est fourni dans un des dossiers de la carte SD fournie avec l'imprimante. C'est peut-être le cas aussi pour Linux

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci, il n'y a pas de drivers sous Linux. Je vais essayer de le brancher sur le PC Windows de ma fille.

Sinon, il semblerait qu'on puisse reflasher la carte avec un USBASP. Je vais voir ça...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 28 minutes, Nibb31 a dit :

Sinon, il semblerait qu'on puisse reflasher la carte avec un USBASP. Je vais voir ça...

Oui, je suis en plein dedans, on peut effectivement compiler un Marlin avec "IDE Arduino/Croquis/Exporter des binaires compilées" mais, comme dit MikeBZH44, tu ne pourras pas piloter ton imprimante directement avec l'ordi, et c'est dommage. Juste jouer avec la SDCard

 

il y a 51 minutes, mikebzh44 a dit :

Par contre, même avec un Marlin dessus, si ton port USB est mort, tu ne pourras pas piloter ton imprimante via OctoPrint.

Ce serait dommage, juste un dépannage.

Mais, sous Linux, il y a pas une histoire qu'il faut déclarer/ouvrir le port, me rappelle plus ..

 

A+

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 6 minutes, Maeke a dit :

As-tu essayé de remplacer ton câble usb?

 

Il y a 2 heures, Nibb31 a dit :

J'ai essayé de le connectet avec plusieurs cables USB,

Partager ce message


Lien à poster
Partager sur d’autres sites

" Drivers are almost certainly built into your Linux kernel already and it will probably just work as soon as you plug it in.  If not you can download the Linux CH340 Driver (but I’d recommend just upgrading your Linux install so that you get the  “built in” one). "

https://sparks.gogo.co.nz/assets/_site_/downloads/CH340_LINUX.zip

Par contre octopi devrait la détecter, ce qui laisse effectivement soupçonner un port usb défectueux.

Regardes page 24 de ce document.

Mais en gros l'auteur te conseille de changer la carte mère.

Modifié (le) par Maeke

Partager ce message


Lien à poster
Partager sur d’autres sites

Avant d'incriminer le firmware, il convient de se poser les questions essentielles

Déjà, est-ce que ce port USB a déjà fonctionné auparavant?

Est-ce qu'il fonctionne en envoyant une demande d'impression à partir du trancheur?

Visuellement, est-ce que les soudures sont bonnes (faire un reflow au fer à souder sur celles-ci ne peut pas faire de mal).

Partager ce message


Lien à poster
Partager sur d’autres sites

La carte est neuve, donc je n'ai pas encore eu l'occasion de tester l'USB. L'imprimante fonctionne bien par ailleurs (j'ai même été surpris par la qualité des premières impressions, sans aucune amélioration de l'imprimante), y compris la carte SD.
Impossible d'envoyer directement depuis Cura puisque l'USB n'est pas reconnu.

Je vais effectivement tenter un reflow des soudures, sur l'USB mais aussi sur les connecteurs du plateau chauffant qui me semblent un peu justes (en attendant le mosfet).

Modifié (le) par Nibb31

Partager ce message


Lien à poster
Partager sur d’autres sites

As-tu bien installé les drivers CH340G qui sont sur la carte SD  ? Sans ta anet ne peux pas être reconnue par le PC

Modifié (le) par medmed

Partager ce message


Lien à poster
Partager sur d’autres sites

Il est sous Linux donc c'est légèrement différent. Et même son Raspberry Pi sous OctoPrint ne voit pas l'imprimante.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai lu en diagonale. Oui, là ça craint. Faudrait tester avec un autre PC pour éliminer toute incompatibilité du matos..

Modifié (le) par medmed

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, Nibb31 a dit :

Merci, il n'y a pas de drivers sous Linux. Je vais essayer de le brancher sur le PC Windows de ma fille.

Je crois que c'est prévu ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 58 minutes, medmed a dit :

J'ai lu en diagonale. Oui, là ça craint. Faudrait tester avec un autre PC pour éliminer toute incompatibilité du matos..

Il a essayé avec un rpi....

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×