Aller au contenu

Anycubic Kobra 3 Combo

BL Touch : axe Z bloqué


Trankiloupilou

Messages recommandés

Salut la commu !

Je fais appel à vous après 2 jours de recherche non fructueuse.

J'ai voulu ajouté le BL Touch de Creality sur ma Ender 3 Pro, je l'ai branché sur la fiche correspondante (carte 4.2.7), je débranche l'ancien capteur Z, je remonte le tout, nickel.

 Je compile donc un nouveau firmware pour ajouter le BL Touch en suivant les instructions à la lettre de KaminoKGY  grâce à sa vidéo détaillée. Je prend bien soin de désactiver Z_MIN_PROBE_USES_Z_MIN_ENDSTOP_PIN et d'activer Z_MIN_PROBE_ENDSTOP pour utiliser la fiche de la carte.

Je met le fichier sur la carte SD, je met sous tension, l'imprimante me demande si je veux initialiser l'EPROM, j'accepte. Le BL Touch s'allume, rentre et sort, OK

Mais lorsque je veux faire un Auto-home impossible de faire descendre l'axe Z, l'écran m'affiche STOPPED. J'ai essayé plusieurs version de Marlin, même résultat. Cependant avec le firmware de Creality j'arrive bien à palper le plateau. Seul problème : la position du BL Touch étant plus éloigné sur mon imprimante que d'origine (Fan Duct Santana), le BLT viens palper dans le vide...

Avez vous une piste à me donner ? Je suis à court d'idée.

Merci d'avance

Lien vers le commentaire
Partager sur d’autres sites

Bonjour,

As-tu mis les bonnes valeurs dans PROBE_OFFSET_FROM_EXTRUDER ?
On peut également le faire en se connectant à l'imprimante

Un peu de lecture :

https://www.cazda.com/bl-touch-sensor-positioning-and-parameters-in-marlin/

De mémoire M851 (à vérifier)

Modifié (le) par icare
Lien vers le commentaire
Partager sur d’autres sites

il y a 35 minutes, icare a dit :

Bonjour,

As-tu mis les bonnes valeurs dans PROBE_OFFSET_FROM_EXTRUDER ?
On peut également le faire en se connectant à l'imprimante

Un peu de lecture :

https://www.cazda.com/bl-touch-sensor-positioning-and-parameters-in-marlin/

De mémoire M851 (à vérifier)

 

Mon PROBE_OFFSET est bien configuré, j'ai rentré les valeurs X -51 et Y -12. Mon problème vient du fait que mon Z ne descend pas pour faire l'origine. C'est avec le firmware du fabriquant que mon BLT sort du plateau, ce qui me fait penser que l'erreur vient de ma compilation mais je ne vois pas du tout ce que c'est.

il y a 39 minutes, papagalak a dit :

@Trankiloupilou, Donc c'est ta compilation qui est en défaut. 

Tu devrais posté tes fichiers config pour que les pro de marlin t'aide

En effet tu as raison. j'ai joint mes fichiers config

Configuration.h Configuration_adv.h

Lien vers le commentaire
Partager sur d’autres sites

il faudrait que tu vérifies que les pins sont les bons dans le fichier pins_CREALITY_V4.h

SERVO0_PIN 

et

Z_MIN_PROBE_PIN

pour les tests de fonctionnement tu peux ensuite utiliser les commandes GCODE suivantes :

M280 P0 S10 ; pushes the pin down
M280 P0 S90 ; pulls the pin up
M280 P0 S120 ; Self test – keeps going until you do pin up/down or release alarm
M280 P0 S160 ; Release alarm

 

Lien vers le commentaire
Partager sur d’autres sites

Sinon ce que je fais quand le firmware n'est pas adapté au probe, c'est renseigné le décalage soit par slicer soit par gcode via pronterface pour l'enregistrer dans l'eeprom.

Au niveau de l'axe Z l'option Z-offset permettre de régler la hauteur.

Lien vers le commentaire
Partager sur d’autres sites

Salut,

Attention la version du firmware (2.1.0.0) de Marlin que tu utilise n'est pas stable (Comme judicieusement rappelé par @fran6p dans un de mes posts), il peut y avoir quelques bugs.

De mon côté je n'ai pas de soucis, mais sait-on jamais ...

As-tu essayé de compiler la version 2.0.9.5 ?

 

Par ailleurs, je n'ai pas approfondis la recherche plus que ca pour ton imprimante mais :

//#define Z_MIN_PROBE_PIN 32 // Pin 32 is the RAMPS default

C'est normal ? Car si il n'est pas connecté au Z_MIN il ne faudrait pas lui indiquer sur quelle pin le BL touch est connecté ?

 

pin 27 ?

 

Je viens de voir qu'il faut rajouter ceci dans le configuration.h :

#define SERVO0_PIN 27

Modifié (le) par Pyroa
Lien vers le commentaire
Partager sur d’autres sites

Comme l'a dit @icareles décalages X,Y et Z peuvent être précisés sans avoir besoin de reflasher un firmware, @juanpaqui ne poste plus régulièrement avait fait un tutoriel :

Pour le problème du Z qui ne descend pas, ça dépend du firmware installé ET surtout de la manière dont est installé le BLT ou CRT (les deux fils servant au détecteur de fin de  course, normalement blanc / noir mais Creality ayant adopté sa «propre» norme il est possible que les couleurs ne correspondent pas).

Le BLT / CRT peut être branché entièrement sur sa prise dédiée ( cinq fils ) ou seulement en partie ( 3 fils ) et le Zstop connecté sur la prise Zmin => dans ces deux cas, le fichier configuration.h n'est pas le même et donc le firmware compilé non plus 😉

🙂

Modifié (le) par fran6p
Lien vers le commentaire
Partager sur d’autres sites

Je reviens vers vous après plusieurs heures de recherche et de test pour vous dire que j'ai enfin résolu mon problème ! Il s'agissait bien d'une erreur de compilation.

En effet il suffisait de

#define USE_PROBE_FOR_Z_HOMING

et modifier la ligne :

    //#define Z_MIN_PROBE_PIN 32 // Pin 32 is the RAMPS default

en : #define Z_MIN_PROBE_PIN 17 // Creality V4.2.7 BLTouch OUT (written on the board)

 

Merci à ceux qui m'ont répondu ainsi que le post de FBR39120 sur lequel j'ai trouvé la solution grâce à son superbe guide PDF trouvable ICI.

Merci encore à tous !

Lien vers le commentaire
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant
  • Sur cette page :   0 membre est en ligne

    • Aucun utilisateur enregistré regarde cette page.
  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...