Aller au contenu

Filament ABS

Marlin 1.1.4 pour DiscoEasy200


Messages recommandés

  • Réponses 134
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Bonjour jofamilly, En fait, la première source d'info sur Marlin, c'est le site Marlin lui meme, Des doc tres bien fait qui te permette de comprendre comment cela fonctionne. En deux, si tu

Posted Images

Il y a 1 heure, Julien-Stalk a dit :

celui de base de chez dagoma j'ai rien modifier encore les printeuse 

ils ont commercialisé 2 types de carte ....

je part sur la base du 1.0

je te conseil donc de re-installer arduino ide en ayant branché ton imprimante en usb au préalable.

installe tout les drivers qu'il va te suggérer et fait les mise a jour spécifié dans le tuto dispo sur thingiverse.

revient vers moi après pour me dire ce que ça a donné....

Lien à poster
Partager sur d’autres sites
  • 2 weeks later...

Bonjour à tous,

je pense que je vais mettre mon Marlin (Discoeasy 200) à jour avec cette version, néanmoins, il y a quelque chose qui me taraude. Si j'ai bien tout compris ce que j'ai lu, vous ne téléversez que le fichier configuration.h ? Qu'en est-il des autres fichiers ? Aucun d'entre eux n'a été modifié dans cette nouvelle version, ne serait-ce que les fichiers language par exemple ?

A la vue des photos, il semblerait que l'icône "plateau chauffant"  non utilisé (comme sur le Marlin RC 6) ait disparu .

Steam

Modifié (le) par Steam
Correction faute
Lien à poster
Partager sur d’autres sites
Il y a 4 heures, Steam a dit :

e pense que je vais mettre mon Marlin (Discoeasy 200) à jour avec cette version

Bonjour stream,

C'est l'intégralité du firmware que tu va televerser. Et pour le plateau chauffant, il faudra juste l'activer et le paramétrer dans configuration.h. et si il y a une douzaine de fichier qui ont été toucher sans compter les évolution de base du Marlin entre ta Rc6 et la 1.1.4.

Pour le chargement du firmware, tu as le tuto qui va avec sur thingiverse. Suis le, et tu n'aura aucun soucis. 

Lien à poster
Partager sur d’autres sites

Bonsoir Gyverblaster,

tout d'abord, merci pour ton travail et pour le partage de celui-ci.

J'ai installé le nouveau firmware sans problème. J'ai également modifié l'histoire du sens du bouton de l'écran, et bien sûr la modification du pas de l'axe Z (tiges trapézoïdales)

J'ai 25 points de palpation pour l'instant et j'ai bien sûr fait une impression.  Étant arrivé au bout du rouleau ;-) de filament, j'ai utilisé la fonction "Changer le filament" qui m'a un peu déroutée au départ. J'ai été très surpris que la buse refroidisse après l'activation de la fonction, mais il suffit de lire les instructions à l'écran et tout fonctionne correctement. Il me reste à trouver la ligne pour indiquer au plateau de s'arrêter à l'avant et non à l'arrière de l'imprimante lors d'un changement de filament.

Concernant le téléversement, j'aurais pensé, qu'après l'ouverture du fichier ino, que seul le programme dont l'onglet était actif été téléchargé dans la carte.

Encore une fois, merci pour le travail et le partage.

Steam

P.S. : Je ne suis pas un courant, mais une vapeur, c'est donc Steam et non Stream ...

Modifié (le) par Steam
Lien à poster
Partager sur d’autres sites

Re bonjour,

la suite de mes découvertes et adaptations de ce Marlin.

J'ai fait le test en disant au logiciel que j'avais un plateau chauffant et effectivement, l'icône s'affiche dans ce cas.

J'ai également modifié le programme "configuration_adv.h" afin que le plateau se positionne à l'avant de la machine lors de changement de filament. En faisant les tests d la fonction "changer le filament" (sans changer de filament), je ne comprenais pas pourquoi je n'extrudais plus et que j'étais obligé de pousser le filament. C'est là que j'ai remarqué , je sais, je ne suis pas doué, que cette fonction, contrairement à l'ancienne version, enfin il me semble, rétractait le filament sur une certaine longueur ! Il ne me reste plus qu'à trouver la variable qui définit cette fonction afin que le filament se rétracte entièrement. Enfin à voir si c'est vraiment utile de le rétracter entièrement. ...

Concernant les 25 points de palpation du plateau, il faut rester à côté du plateau car la buse étant en chauffe et que le filament sort de la buse, avec les 25 points, un bouchon commence à se former sur la buse, qu'il faut absolument enlever avant de commencer l'impression.

Je me répète, mais encore une fois merci  à Gyverblaster pour son boulot et le partage et aussi à Jey qui nous a évité bien des soucis de branchements..

Steam

Lien à poster
Partager sur d’autres sites
Il y a 6 heures, Steam a dit :

Concernant les 25 points de palpation du plateau, il faut rester à côté du plateau car la buse étant en chauffe et que le filament sort de la buse, avec les 25 points, un bouchon commence à se former sur la buse, qu'il faut absolument enlever avant de commencer l'impression.

Si tu veux éviter ce souci, démarre la chauffe apres la palpation dans ton slicer. Et la c'est magique....

Ton capteur induction sera plus précis (Ça ne vaudra jamais un bl-touch, mais c'est assez surprenant quand meme) et fini l'usage de la petite pince pour enlever les résidu de pla

Lien à poster
Partager sur d’autres sites

Re bonjour Gyverblaster,

Je ne suis vraiment pas doué, comme déjà dit, car je viens de refaire un tour sur le lien de Thingiserve et j'ai vu que tu y indiquais comment modifier la position du plateau pour le changement de filament ... Bon, moi je l'ai changé dans dans le programme "configuration_avh.h".

En ce qui concerne le démarrage de la chauffe après la palpation, je suis moins convaincu, car si tu fais plusieurs impressions à la suite, il faudrait attendre le refroidissement total de la tête pour que ton offset soit juste.

Pour l'offset justement, dans l'ancienne version, lorsque l'on modifiait l'offset depuis l'écran, la tête se déplaçait et restait dans la position du réglage, ce qui permettait de glisser un feuille de papier sous la tête et ajuster l'offset et l'affiner (et éventuellement régler le plateau en plusieurs points si celui-ci est réglable). Dans cette version 1.1.4, lorsque l'on règle une valeur de l'offset depuis l'écran, la tête se déplace en position et fait de suite un homing, ce qui empêche tout affinage (loin de moi, l'idée d'en faire un fromage).

Concernant cette version 1.1.4, sur le fil consacré au BLtouch, tu indiques que cette version n'est pas compatible avec le BLTouch, pourtant je vois ces lignes dans le "configuration.h" :

//#define BLTOUCH
#if ENABLED(BLTOUCH)
  //#define BLTOUCH_DELAY 375   // (ms) Enable and increase if needed
#endif

/**

Cette version est-elle compatible ou pas ?

J'ai été un peu long, j'en suis désolé.

Steam

Modifié (le) par Steam
Lien à poster
Partager sur d’autres sites
Il y a 14 heures, Steam a dit :

En ce qui concerne le démarrage de la chauffe après la palpation, je suis moins convaincu, car si tu fais plusieurs impressions à la suite, il faudrait attendre le refroidissement total de la tête pour que ton offset soit juste.

Tu laisse juste le temps de refroidir entre tes impressions, c'est le prix de la qualité.... tu évitera bien des problème de warping, de trou ou de pâté sur ta première couche. C'est juste pour palier au problème de qualité du palpeur et du plateau.

 

Il y a 14 heures, Steam a dit :

lorsque l'on règle une valeur de l'offset depuis l'écran, la tête se déplace en position et fait de suite un homing, ce qui empêche tout affinage

Crois-en mon expérience, plus tu met de truc réglable, plus t'as des chance que cela se dérègle.... Il vaut mieux avoir un truc fixe. Donc pour ce faire, fait évoluer ta machine avec des barre de renfort diagonale des su peut réglé et serrer... cela renforcera l'equerage de ta belle, et cela ne bougera plus. Et si tu as la chance de passer un jour sur un plateau en verre, et que ta machine en calibrer et fixer, tu te passera même du g29...

 

Il y a 14 heures, Steam a dit :

Concernant cette version 1.1.4, sur le fil consacré au BLtouch, tu indiques que cette version n'est pas compatible avec le BLTouch

Tu peux configurer la 1.1.4 avec un bltouch. C'est juste que la version téléchargeable n'est pas "bl-touch ready" comme la version 1.1.6 que j'ai diffuser dans le fil. A ce sujet, si tu as lu, tu à pu voir à quel point on a galérer pour les faire fonctionner... maintenant, il suffit de saisir les réglage de la 1.6 dans la 1.4 et cela fonctionnera nickel

J'espère avoir été assez clair dans mes réponses. C'est un peu difficile d'y répondre en quelques lignes tant ces sujets sont fast....

Si tu as besoin de plus de précision.. .. tu n'hésite pas

Lien à poster
Partager sur d’autres sites

Je n'hésite pas aloes.

Comme tu as pu le lire sur le fil dédié au BLtouch dans la rubrique Dagoma, je viens de commander un de ces palpeur et je vais certainement utiliser ta version 1.1.6 en, si j'ai bien compris, modifiant le branchement des endstops X et Y. Je pense que pour ce qui est des commandes depuis l'écran, cela doit être pareil qu'avec la version 1.1.4.

Il y a quelque chose qui m'interroge un peu dans le programme "configuration.h" de la version 1.1.4, c'est qu''il y 17 pour le le type de sonde pour la tête. Pourquoi pas simplement 1 (100K) ?

Pour info, ma Discoeasy a pour l'instant été modifiée comme suit :

- Tiges filetées trapézoïdales (Stan 42)

- Barres de renfort  (Bezain)

- Remplacement des LM8UU par des Igus sur X et Y ( j'ai constaté un jeu important dans la tête et j'ai du ajouter de la carte plastique de 0.2 ou 0.15, je ne sais plus, pour supprimer ce jeu)

- Ajout d'un plateau chauffant (non encore fonctionnel) monté sur ressort, d'où mon histoire de réglage et d'affinage, mais en utilisant une cale, on peut règler la hauteur du plateau en différents points.

Steam

Lien à poster
Partager sur d’autres sites

Bonjour à tous , je me permets de vous contacter pour évoquer mes soucis avec cette "chère" imprimante je viens de faire les modifs proposées par Gyverblaster en me disant ça y est quelqu'un à trouvé pour faire fonctionner cette imprimante de m....., et au passage je le remercie pour son excellent tuto

Mais voilà je ne dois pas être doué, mes problèmes car il y en a plusieurs :

1 J'ai beau modifier la valeur du Z à l'écran ça ne change pas grand chose je n'arrive pas à écraser le PLA, et ça depuis toujours ....

2 A la mise en chauffe j'ai le ventilo arrière qui démarre et l'avant arrivé à 51° aussi, contrôles de l'imprimante et tout semble normal, mais voilà qu'au moment de l'impression le ventilo arrière s'arrête et ce remet en marche au bout de quelques secondes (désolé j'ai pas chronométré), donc j’arrête tout car ça part en sucette.

J'ai installé le Marlin 1.1.4_DE200_Affichage_couche sans problème, le tuto est vraiment super, apporté les modifs pour le plateau chauffant, il me reste à modifier la séance de palpage du plateau un peu longue, pour le reste on verra.

Mon matériel :

Discovery partiellement modifiée je n'en ferai pas plus arrivé à un moment ça ne vaut plus trop le coup, donc tête DiscoEasy montée sur ma DiscoVery200, plateau chauffant,écran, et platine MKS Base 1.0 ( de chez DagochosedemesdeuxMa),

A l'affichage info imprimante j'ai : MARLIN 1.1.4 2017-07-04 12:00 DiscoEasy 22.

L'Offset au départ était égal à -0.40 et que j'ai passé à -0.61voir -0.70, j'utilise Ultimaker Cura 3.0.4, et dans le Gcode début et fin j'ai téléchargé la dernière version trouvée sur le site.

Bon voilà je crois que j'ai tout écrit, et j'espère au bon endroit , et bien sur je vous remercie si vous pouvez me venir en aide, je pense qu'il vous faudra un peu d'indulgence et beaucoup de patience, parce-que à force je commence à vraiment nager dans la semoule.

Merci à vous Jean-Luc

Modifié (le) par Trutru
Lien à poster
Partager sur d’autres sites

Bonjour,

sans être un spécialiste, le ventilateur arrière, celui qui refroidit la matière déposée, s'arrête lors de l'impression de la première couche.

Quand tu modifies ton offset, il faut que tu fasses "sauvegarde Config", sinon ta valeur ne sera pas sauvegardée.

Steam

Lien à poster
Partager sur d’autres sites

Bonsoir Steam

Et merci pour ton suivi, le problème du ventilo est qu'il s’arrête pendant 40s après le message "Impression en cours" ( j'ai chronométré ), juste le temps de la jupe et un début de la 1er couche, j'aimerai savoir si on peut supprimer cette tempo, si c'est bien une tempo dans le Marlin.

Et pour la sauvegarde effectivement il me semble avoir oublié après mes modifs (l'ancienne version), ne sauvegardait que dalle, je contrôlerai ça demain.

Une dernière chose dans le  Start GCode doit-on indiquer Offset du Z à travers G1Z-.... (valeur lu sur le Z de l'imprimante), il me semble avoir vu un exemple de Gcode avec cette ligne, ou cette version du Marlin n'a pas besoin de cette précision

Bonne Soirée JL

Lien à poster
Partager sur d’autres sites
il y a 38 minutes, Trutru a dit :

j'aimerai savoir si on peut supprimer cette tempo,

Hello trutru....

Comme la dit steam, ce n'est pas une tempo mais un truc que ton slicer fait pour éviter le warping et maximiser l'adherence.

Si tu veux le faire sauter, c'est dans les paramètre du slicer que tu doit chercher.

Lien à poster
Partager sur d’autres sites

Bonjour Gyverblaster et merci pour tes réponses
 

Il y a 8 heures, Gyverblaster a dit :

Hello trutru....

Comme la dit steam, ce n'est pas une tempo mais un truc que ton slicer fait pour éviter le warping et maximiser l'adherence.

Si tu veux le faire sauter, c'est dans les paramètre du slicer que tu doit chercher.

Donc dans Ultimaker Cura j'ai supprimé dans le Gcode de début le "G1", ensuite j'ai trouvé dans les paramètres du slicer section "Refroidissement" des paramètres à ajouter sur la vitesse des ventilateurs en fonction des couches je vais donc tenter le coup on verra ...

Pour le Warping et l'adhérence que je n'ai pas, malgré le plateau chauffant et le buildtak , je pense que cela vient de ma 1er couche trop haute et donc pas assez écrasée

Je vous tiens au courant et merci à vous

Lien à poster
Partager sur d’autres sites

Bonjour Steam bonjour Gyverblaster, un nouveau message pour vous donner des nouvelles

Grace à vous les impressions sont régulières et bien meilleures, aussi j'ai modifié les paramètres du Marlin pour éviter le contrôle du plateau sur 25 points, j'ai une question mais plus pour le fun , peut-on avoir les 2 pictogrammes des ventilateurs un pour la tête l'autre pour le plateau et en plus avec chaque vitesse sur l'un et l'autre .

Enfin une dernière pour ne pas polluer cette rubrique existe-t-il une rubrique pour déposer les photos des impressions et demander un avis sur un possible problème de la dite impression

Enfin pour finir merci à vous deux j'ai tellement galéré avec cette pu... d'imprimante que je ne savais plus ou j'en étais.

Cordialement Jean-Luc

Modifié (le) par Trutru
Lien à poster
Partager sur d’autres sites

Chers amis re

Je crois que je jette l'éponge impossible d'avoir une impression correcte , je pense prendre la carte de crédit et acheter une imprimante 3D même made in ce qu'on veut mais pas cette GROSSE M

Si quelqu'un connais et votre avis  : https://www.reprap-france.com/produit/1234568399-prusa-i3-rework-1-5

Ou si vous avez une meilleure idée

Merci à vous Jean-Luc

Modifié (le) par Trutru
Lien à poster
Partager sur d’autres sites

Salut Trutru,

il ne faut pas jeter l'éponge aussi vite. Tu verras que les galères d'aujourd'hui te permettront de trouver les solutions à tes problèmes futurs.

Pour les remerciements, c'est surtout Gyverblaster qui les mérite, pas moi, je n'ai rien fait !

Pour ce qui est de l'affichage des ventilos, afficher celui qui est à l'avant ne sert pas à grand chose, il semet en route dès que la sonde de corps de chauffe détecte plus de 50° et s'arrête quand cette température passe en dessous de 50°. Concernant le ventilateur arrière, c'est lui qui est affiché sur l'écran et lors de l'impression, il affiche le pourcentage que tu auras indiqué dans ton slicer. Chez moi, comme j'ai la tête V3 de chez Dagoma, j'ai réglé ce pourcentage à 65%, pourcentage donné par Dagoma.

Pour ce qui est de tes problèmes d'impression et pour poster tes photos, il y a un sujet "Dagoma" dans la rubrique "les constructeurs", vas-y faire un tour.

Le lien : https://www.lesimprimantes3d.fr/forum/41-dagoma/

Je te mets aussi ce lien pour les différents problèmes d'impression :

https://www.logre.eu/wiki/RepRap_printDoctor

Steam

Modifié (le) par Steam
Ajout lien
Lien à poster
Partager sur d’autres sites

Bonsoir Steam et merci à toi pour tes encouragements ,demain je continuerai, je ne désespère pas, enfin pas trop, mais depuis plus de 2 ans que j'ai cette imprimante de M... je n'ai jamais au grand jamais réussi à avoir une qualité d'impression régulière , ce matin pas exemple offset Z nickel 4 ou 5 pièces avec une impression très convenable et sans savoir ni pourquoi ni comment impossible de refaire coller le PLA au plateau. Au fait précisé mais j'ai aussi monté une tête V3 (pfff)

Merci pour ton G code, tu l'utilises avec quel slicer , pour ma part et dans mes essais j'alterne avec Ultimaker Cura 3.0.4 & Cura 15.04.6, je comparerai par rapport aux miens et je te dirai

Merci encore et bonne soirée

Jean-Luc

Lien à poster
Partager sur d’autres sites

C'est le start code que j'ai mis dans Cura 2.5.

Avec un capteur inductif comme sur nos machines, j'ai constaté que lorsque l'on imprime plusieurs pièces de suite, la mesure du capteur peut changer et généralement, je dois régler mon offset afin de dire à la tête de descendre encore plus bas quand celle-ci est chaude. Dans mon start-code, je palpe avant de mettre la tête en chauffe. C'est une modification que j'ai faite il y a 2 jours sur le conseil de Gyverblaster. Avant je chauffais d'abord et je palpais ensuite. Maintenant, j'attends que la tête refroidisse avant de relancer une impression pour écarter tant que faire se peut, les fluctuations dues à la température.

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...