Aller au contenu

Filament ABS

Marlin 1.1.4 pour DiscoEasy200


Messages recommandés

Bonjour à tous, voilà je reviens vers vous en espérant ne pas vous ennuyer, on m'a dit de persévérer, donc j'écoute mais vais-je dans le bon sens ?

Voilà j'ai "retéléversé" le marlin 1.1.4 (j'ai vu qu'il y a 1.1.6 qu'elles diffs ?), entré ma hauteur offset , et toujours pareils : pas toujours la même épaisseur d'accroche , etc etc , j'ai donc essayé dans configuration.h divers contrôle dans la section @section bedlevel ligne 789-834 environ, et j'avoue être un peu perdu , l'origine est AUTO_BED_LEVELING_BILINEAR mais voilà 25 points de contrôle (pfff un peu long), j'ai donc essayé AUTO_BED_LEVELING_3POINT, pas très convaincu ..., j'ai ensuite essayé AUTO_BED_LEVELING_UBL, Ouah-ou là, il faut maitriser une usine à gaz et votre humble utilisateur était perdu, pourtant j'ai eu quelques résultats probants .

Donc je vais essayer de reprendre à zéro, T° extrusion 210°, T° plateau 55°, T° pièce 16° là effectivement c'est pas beaucoup, mais il me semble qu'avec mes choix sur l'imprimante ça devrait, non ?, question faut-il équiper cette imprimante de M... de vis de réglages pour faire un réglage parfait du plateau, peut-on faire un contrôle du plateau avec AUTO-BED_LEVELING à la fois étendu (en surface ) et réduit (en nombres de points de contrôle), de plus quand il lance le contrôle du plateau j'ai un "claquage" du pas à pas Y quand la tête arrive devant à gauche il me semble avoir entré les bonnes dimensions du plateau dans CURA

Voili Voilou merci de me venir en aide Jean-Luc

Modifié (le) par Trutru
Lien à poster
Partager sur d’autres sites
  • Réponses 134
  • Created
  • Dernière réponse

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Bonjour jofamilly, En fait, la première source d'info sur Marlin, c'est le site Marlin lui meme, Des doc tres bien fait qui te permette de comprendre comment cela fonctionne. En deux, si tu

Posted Images

Le 23/11/2017 at 11:56, Trutru a dit :

Bonjour à tous, voilà je reviens vers vous en espérant ne pas vous ennuyer, on m'a dit de persévérer, donc j'écoute mais vais-je dans le bon sens ?

Voilà j'ai "retéléversé" le marlin 1.1.4 (j'ai vu qu'il y a 1.1.6 qu'elles diffs ?), entré ma hauteur offset , et toujours pareils : pas toujours la même épaisseur d'accroche , etc etc , j'ai donc essayé dans configuration.h divers contrôle dans la section @section bedlevel ligne 789-834 environ, et j'avoue être un peu perdu , l'origine est AUTO_BED_LEVELING_BILINEAR mais voilà 25 points de contrôle (pfff un peu long), j'ai donc essayé AUTO_BED_LEVELING_3POINT, pas très convaincu ..., j'ai ensuite essayé AUTO_BED_LEVELING_UBL, Ouah-ou là, il faut maitriser une usine à gaz et votre humble utilisateur était perdu, pourtant j'ai eu quelques résultats probants .

Donc je vais essayer de reprendre à zéro, T° extrusion 210°, T° plateau 55°, T° pièce 16° là effectivement c'est pas beaucoup, mais il me semble qu'avec mes choix sur l'imprimante ça devrait, non ?, question faut-il équiper cette imprimante de M... de vis de réglages pour faire un réglage parfait du plateau, peut-on faire un contrôle du plateau avec AUTO-BED_LEVELING à la fois étendu (en surface ) et réduit (en nombres de points de contrôle), de plus quand il lance le contrôle du plateau j'ai un "claquage" du pas à pas Y quand la tête arrive devant à gauche il me semble avoir entré les bonnes dimensions du plateau dans CURA

Voili Voilou merci de me venir en aide Jean-Luc

Au vu des soucis que tu rencontre, reste sur une valeur sur qui a fait ces preuves : donc sur le 1.1.4 

Règle la hauteur z par rapport à ton plateau à gauche et à droite (au pied à coulisse, c'est bien)

Garde le palpable en 5 pts, surtout vu les problème que tu as. (Je t'aurai même conseillé de passer à 7 pts....)

Démarre la chauffe de la tête apres la palpation.

Ne ventile pas sûr la première couche

Chauffe ta première couche à 230 degrés et passe à 215 pour la suite

17mm/s pour la première couche et les contour et 40 pour le rempliessayé

Passe par un raft si tu recontre un probleme d'adhesion

Si après cela, tu as toujours un soucis c'est que tu as un soucis matériel ou que ton offset est mal réglé. 

Lien à poster
Partager sur d’autres sites

Bonjour Gyverblaster , et merci à toi pour ton suivi

Je suis toujours sur le Marlin 1.1.4, la hauteur du Z est bien contrôlée au pied à coulisse, du plateau avec la 1er barre horizontale du X (ajustement fait avec les tiges filetées des moteurs Z), par contre le contrôle plateau que j'ai ce fait en 20pts (et non 25, donc si je peux diminuer ..., sans trop perdre en fiabilité), je démarre bien la chauffe de la tête après le contrôle plateau, et je ne ventile le palpeur que durent le contrôle du plateau, ensuite arrêt du ventilo le temps de quelques couches et redémarrage jusqu'à la fin de l'impression.

Par contre je ne  sais pas comment faire le choix des 2 T° je pense que c'est dans Cura, je suis avec Cura Ultimaker 3.0.4, mais je vais chercher.

Je n'avais pas repris le fil mais ces derniers temps j’obtenais un impression relativement régulière, et pour finir PATATRAC, j'ai voulu contrôler mon imprimante à travers Cura et Octoprint, et maintenant j'ai le palpeur qui ne fonctionne plus, donc la buse se plante dans le buildtak, aussi ce matin (si j'ai un peu de temps) je réinstalle le Marlin,  j'ai trouvé un autre paramètre que je vais tenter d'utiliser le LCD_BED_LEVELLING (si tu connais) qui crée un sous-menu Bed Leveling à l'écran LCD .

Une dernière chose j'ai reçu un kit de vis & ressort,  pour mettre le plateau de niveau, tu en penses quoi

On se tient informé et encore merci, cordialement Jean-Luc

Modifié (le) par Trutru
Lien à poster
Partager sur d’autres sites

Bonjour Gyverblasrer et désolé du retard

Je vais te faire une réponse (partielle si tu veux bien), la buse fait bien le centrage du plateau avant de faire le leveling, pour le config.h (si je peux je te le fais parvenir dans la journée, hier soir dans un moment de libre je l'ai modifié pour le téléverser, je te remets les paramétrage  et je te l'envoie.)

Configuration.h sauf erreur fait et joint ... + je rajoute le Gcode début dans Ultimaker Cura

Pour l'instant à par le claquage du moteurs Y  au moment du leveling ,j'arrive à seulement 9 points de contrôle, mais  je n'arrive pas à forcer l'offset pour écraser un peu plus la 1er couche, mon origine est -0.84, j'essaye -0.90 et ça ne l'écrase pas plus, là je ne comprends pas pourquoi ?

Mon message est un peu confus, je te dis partiel puis je rajoute etc etc :$, donc je crois à part la photo, avoir répondu à ta demande pour me venir en aide.

Quand tu peux , je ne suis "pas trop pressé", encore merci à toi en plus c'est dimanche O.o

A bientôt et encore merci

Jean-Luc

 

 

Configuration.h

Gcode début.txt

Modifié (le) par Trutru
Lien à poster
Partager sur d’autres sites
  • 1 month later...

MERCI !!!!!!!!!!!!!!!!!! 

Merci à toi Gyverblaster !!!! 

Depuis que j'ai installé tin Firmware, je redécouvre ma machine :

Plus de claquement de l'extrudeur, plus de différence entre les couches, réglage plateau top !!!

Comme évoqué dans un autre poste, il ne me reste plus qu'un (petit) bug, mais qui à mon sens n'a rien à voir avec le firmware plusqu'il est apparu juste avant que je le flash : j'ai un décalage d'1 cm entre Cura by Dagoma et le plateau de ma Discoeasy :  Même si je centre la pièce sur la plateforme, quand je lance l'impression, celle-ci se déroule sans accroc... mais avec un décalage d'1 cm sur la droite (axe X)...

 

Si quelqu'un à une idée, je suis preneur.

 

Merci à tous :1_grinning: 

Lien à poster
Partager sur d’autres sites
Le 26/11/2017 at 10:38, Trutru a dit :

Bonjour Gyverblasrer et désolé du retard

Je vais te faire une réponse (partielle si tu veux bien), la buse fait bien le centrage du plateau avant de faire le leveling, pour le config.h (si je peux je te le fais parvenir dans la journée, hier soir dans un moment de libre je l'ai modifié pour le téléverser, je te remets les paramétrage  et je te l'envoie.)

Configuration.h sauf erreur fait et joint ... + je rajoute le Gcode début dans Ultimaker Cura

Pour l'instant à par le claquage du moteurs Y  au moment du leveling ,j'arrive à seulement 9 points de contrôle, mais  je n'arrive pas à forcer l'offset pour écraser un peu plus la 1er couche, mon origine est -0.84, j'essaye -0.90 et ça ne l'écrase pas plus, là je ne comprends pas pourquoi ?

Mon message est un peu confus, je te dis partiel puis je rajoute etc etc :$, donc je crois à part la photo, avoir répondu à ta demande pour me venir en aide.

Quand tu peux , je ne suis "pas trop pressé", encore merci à toi en plus c'est dimanche O.o

A bientôt et encore merci

Jean-Luc

 

 

Configuration.h

Gcode début.txt

Desole pour le retard, ton post est passe inaperçu.....

Pour que ta valeur l'offset soit prise en compte il faud que tu aille sur sauver config et faire un appuis long dessus.

Pour la 2eme temp, tu active dans matériaux, température couche initiale

 

Pour le gcode de debut (Si T'as pas de plateau chauffant, vire la ligne en gras):

M117 Initialisation de l'imprimante

G90 ;absolute positioning

M117 Auto-bed level...

M280 P0 S160 ; BLTouch alarm release

G4 P100 ; delay for BLTouch

G28 ; home

G29 ; auto bed leveling

G1 X20 Y20 F6000

M140 S{material_bed_temperature}

M104 S{material_print_temperature_layer_0}

M109 S{material_print_temperature_layer_0}

G1 Z0.5

M117 Initialisation Extruder...

M82 ;set extruder to absolute mode

G92 E0 ;initialisation Extrudeur

G1 F200 E15 ;extruder 15mm

G92 E0 ;initialisation Extrudeur

G1 Z3

G1 F6000

M117 Impression en cours...

 

Pour config.h, je regarde et te recontacte

Lien à poster
Partager sur d’autres sites
Il y a 4 heures, xufamifa a dit :

MERCI !!!!!!!!!!!!!!!!!! 

Merci à toi Gyverblaster !!!! 

Depuis que j'ai installé tin Firmware, je redécouvre ma machine :

Plus de claquement de l'extrudeur, plus de différence entre les couches, réglage plateau top !!!

Comme évoqué dans un autre poste, il ne me reste plus qu'un (petit) bug, mais qui à mon sens n'a rien à voir avec le firmware plusqu'il est apparu juste avant que je le flash : j'ai un décalage d'1 cm entre Cura by Dagoma et le plateau de ma Discoeasy :  Même si je centre la pièce sur la plateforme, quand je lance l'impression, celle-ci se déroule sans accroc... mais avec un décalage d'1 cm sur la droite (axe X)...

 

Si quelqu'un à une idée, je suis preneur.

 

Merci à tous :1_grinning: 

Tu as essayer avec un autre slicer, genre cura 3.1....

Vérifie que tes fin de course soit bien en place (sur X vu ton souci et qu' il vienne bien déclencher contre le corp de la tete et non sur une vis ou un bout de sangle....)

Modifié (le) par Gyverblaster
Lien à poster
Partager sur d’autres sites
  • 1 month later...
Le 09/01/2018 at 14:26, xufamifa a dit :

MERCI !!!!!!!!!!!!!!!!!! 

Merci à toi Gyverblaster !!!! 

Depuis que j'ai installé tin Firmware, je redécouvre ma machine :

Plus de claquement de l'extrudeur, plus de différence entre les couches, réglage plateau top !!!

Comme évoqué dans un autre poste, il ne me reste plus qu'un (petit) bug, mais qui à mon sens n'a rien à voir avec le firmware plusqu'il est apparu juste avant que je le flash : j'ai un décalage d'1 cm entre Cura by Dagoma et le plateau de ma Discoeasy :  Même si je centre la pièce sur la plateforme, quand je lance l'impression, celle-ci se déroule sans accroc... mais avec un décalage d'1 cm sur la droite (axe X)...

 

Si quelqu'un à une idée, je suis preneur.

 

Merci à tous :1_grinning: 

Salut !

Après avoir lu entièrement le fil, je pense que je vais flash le firmware ^^

Pour ton problème de décalage j'ai aussi été embeté. J'en ai parlé à Dagoma, y'a un bon moment d'ailleurs et ils m'ont dit de retirer la petite partie en métal de l'interrupteur de fin de course, ce que j'ai fait et depuis plus de décalage même après l'avoir démonté et remonté entièrement.

Tiens moi au courant :)

Lien à poster
Partager sur d’autres sites

J'ai flash le firmware et c'est vrai que c'est pas mal du tout ! Encore merci pour ce partage.

Voici ce que j'en pense : c'est bien, même très bien !

Y'a quand même 2-3 petits trucs : le G28 est long je trouve par rapport au firmware d'origine, même si il permet de placer la tête à 1 cm du plateau, c'est lent car la tête redescend tout doucement, mais on s'y fait et au final c'est quand même plus pratique. Deuxième truc, le G29, les moteurs "vibrent" lors de la descente mais ce n'est pas gênant, et certains disaient avoir des problèmes d'un paquet qui se fait sous la buse pendant la mise à niveau, pour y remédier, car je ne suis pas du tout embêté avec ça, je vous propose ma version de gcode (cf fichier joint).

gcode.txt

Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×
×
  • Créer...