Aller au contenu

Filament ABS

CacaoTor

AlfaWise U20x-U30 : Marlin Configuration, Optimisation, Périphériques

Messages recommandés

@boleofr échec ici pour ta pièce 😞

Des décalages en Y malgré des paramètres à ras des pâquerettes!
 

/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_FEEDRATE          { 200, 200, 50, 25 }

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_ACCELERATION      { 300, 300, 10, 3000 }

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          300    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  400    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   300    // X, Y, Z acceleration for travel (non printing) moves

/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_FEEDRATE          { 200, 200, 50, 25 }

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_ACCELERATION      { 300, 300, 10, 3000 }

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          300    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  400    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   300    // X, Y, Z acceleration for travel (non printing) moves

 

IMG_20190426_162640.jpg

IMG_20190426_162519.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 4 minutes, oudini a dit :

@boleofr échec ici pour ta pièce 😞

Des décalages en Y malgré des paramètres à ras des pâquerettes!
 


/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_FEEDRATE          { 200, 200, 50, 25 }

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_ACCELERATION      { 300, 300, 10, 3000 }

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          300    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  400    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   300    // X, Y, Z acceleration for travel (non printing) moves

/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_FEEDRATE          { 200, 200, 50, 25 }

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_ACCELERATION      { 300, 300, 10, 3000 }

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          300    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  400    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   300    // X, Y, Z acceleration for travel (non printing) moves

 

IMG_20190426_162640.jpg

IMG_20190426_162519.jpg

Jette un œil sur ta courroie et galet Y. 

Attention dans ton slicer aux paramètres d'accélérations et jerk également.

Modifié (le) par CacaoTor

Partager ce message


Lien à poster
Partager sur d’autres sites

pour la version de @boleofr j'ai sortis le benchy sans decalage Y a 60mm/s le seul vraiment gros truc qui me fait peur ,c'est le déplacement du bed :x il tape a fond dans la fin de courses en Y

 

j'ai inversé le roulement du Z depuis le debut que j'ai l'alfawise l’épaulement du roulement se retrouve au dessus au lieu d'etre bloqué en sandwich entre les 2 supports 

Modération : Post déplacé dans le bon sujet

Modifié (le) par clemb44

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, CacaoTor a dit :

Merci pour ce très bon retour !

Je vais également tenter des tests dans la journée et reste de la semaine, en tentant de séparer l'aspect méca du sofware (Cura) et software (Marlin). Y'a vraiment tout à ré-étudier depuis qu'on a un vrai firmware (désolé du troll 😛).

Au fait, je suis un peu arrivé en douce sur le sujet sans claquer la bise.

Je tenais à remercier tous les très gros bosseurs qui ont pu permettre ce portage sur nos petites Alfawise.

Vraiment très bon boulot les gars !

De plus, on pourrait croire que vous n'avez que ça à faire, mais certains d'entre-vous on quand même un travail et des occupations prioritaires à côté, donc ça vaut vraiment un très gros MERCI !!!

  • Merci ! 2

Partager ce message


Lien à poster
Partager sur d’autres sites

@oudini aurais tu le lien du fichier stl que je test aussi de mon coté , il faudrait que l'on ai les memes pieces pour comprendre mieux ...

 

le seul truc que je change a chaque fois c'est les pas/mm mais je suis a 79.5 au lieu de 80 ... 

Modifié (le) par clemb44

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 15 minutes, oudini a dit :

a la fin de la page 46 sur l'autre fil

ouai trouvé je suis en cours de print a 60mm/s on verra si le décalage arrive sur cette piece.

 

va falloir que je revois mon leveling ... mais ça le fera quand meme 

Modifié (le) par clemb44

Partager ce message


Lien à poster
Partager sur d’autres sites

En vrac... Montage des dampers... Touch-mi reçu (mais pas monté)

un firmware un peu moins bridé

/**
 * Default Max Acceleration (change/s) change = mm/s
 * (Maximum start speed for accelerated moves)
 * Override with M201
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4[, E5]]]]]
 */
#define DEFAULT_MAX_ACCELERATION      { 500, 400, 20, 3000 }

/**
 * Default Acceleration (change/s) change = mm/s
 * Override with M204
 *
 *   M204 P    Acceleration
 *   M204 R    Retract Acceleration
 *   M204 T    Travel Acceleration
 */
#define DEFAULT_ACCELERATION          500    // X, Y, Z and E acceleration for printing moves
#define DEFAULT_RETRACT_ACCELERATION  300    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   300    // X, Y, Z acceleration for travel (non printing) moves

Je lance une pièce à problème l'impression puis un support pour mes tlsmoothers si ok

project.bin

Partager ce message


Lien à poster
Partager sur d’autres sites

@oudini j'ai vu ... mais je en sais pas quoi en déduire, c'est quasi pareil que le bridage précédent et ça fonctionne chez moi... D'où le test ce soir. 

Niveau défaut, c'est très très similaire on dirait le même endroit

Modifié (le) par boleofr

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, oudini a dit :

trancheur alors ?

Tu es parti du gcode posté ? Si oui alors c'est pas le trancheur

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai fais le module activateur du touch-mi avec Marlin puis avec Alfawize, j'ai eux un mille-feuilles avec Marlin et une pièce nickel avec Alfawize, ça fout les boules!

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, oudini a dit :

oui j'ai utilisé ton G-code direct (il m'a d'ailleurs dégagé une pince au démarrage)

Tu as tout fait sauf ça visiblement. Et il ne reste d’ailleurs que ça.

Modifié (le) par CacaoTor

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 19 minutes, oudini a dit :

oui j'ai utilisé ton G-code direct (il m'a d'ailleurs dégagé une pince au démarrage)

Ah merde, désolé j'ai pas pensé à ça... perso pince décalé le long de Y de ce coté là

il y a 21 minutes, oudini a dit :

J'ai fais le module activateur du touch-mi avec Marlin puis avec Alfawize, j'ai eux un mille-feuilles avec Marlin et une pièce nickel avec Alfawize, ça fout les boules!

Aie... Je vais tester aussi (quitte à imprimer autant faire des pièces utiles), tu as le gcode ?

Modifié (le) par boleofr

Partager ce message


Lien à poster
Partager sur d’autres sites

bon bas moi j'ai pris cura dans mon coin :x 60mm/s du gros claque et deviné lol j'attend la fin de piece pour faire voir les dégâts 

 

une impression de claquement de la courroie :x 

Modifié (le) par clemb44

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 2 minutes, CacaoTor a dit :

Tu as tout fait sauf ça visiblement. Et il ne reste d’ailleurs que ça.

Oui, c'est pas bête. De mon coté j'ai revu les réglages avec un peu moins de tension because désaxage des moteurs à cause des dampers...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 5 minutes, boleofr a dit :

Oui, c'est pas bête. De mon coté j'ai revu les réglages avec un peu moins de tension because désaxage des moteurs à cause des dampers...

Un grand classique.

Beaucoup on imprimé ça pour corriger l'angle de décalage : https://www.thingiverse.com/thing:3376491 (avec un PLA solide). A noter que la courroie de Y déguste beaucoup à cause des chauffes du bed. En fait si on regarde bien, Y est l'axe le plus violemment sollicité avec E en cas de buse régulièrement bouchée.

Modifié (le) par CacaoTor

Partager ce message


Lien à poster
Partager sur d’autres sites

@CacaoTor Tu as raison, c'est un point crucial mais c'est évidement la première chose que j'ai faite.

Ma courroie est correctement tendue, mes pignons sont bien serrés sur leurs axes.

Les galets sont quasi neufs.

Le plateau se déplace à frottement gras sur toute sa course.

Mécaniquement j'en conclu que c'est bon.

De plus sous Alfawize, même si les contraintes sont moins fortes que sous Marlin, tout s'imprime parfaitement.

EDIT : Je n'ai pas de damper

Modifié (le) par CacaoTor

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, oudini a dit :

@CacaoTor Tu as raison, c'est un point crucial mais c'est évidement la première chose que j'ai faite.

Ma courroie est correctement tendue, mes pignons sont bien serrés sur leurs axes.

Les galets sont quasi neufs.

Le plateau se déplace à frottement gras sur toute sa course.

Mécaniquement j'en conclu que c'est bon.

De plus sous Alfawize, même si les contraintes sont moins fortes que sous Marlin, tout s'imprime parfaitement.

Ta courroie ne frotte jamais le profilé ? Le moteur est parfaitement dans l'axe ?

Quelle version de carte-mère as-tu ? Et même question pour @boleofr ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, CacaoTor a dit :

Quelle version de carte-mère as-tu ? Et même question pour @boleofr ?

V07

Partager ce message


Lien à poster
Partager sur d’autres sites

Donc, tu as exactement les mêmes conditions de test software et carte-mère que @boleofr et ton Y se décale ?

EDIT : Quid de ton vRef du driver Y ?

Modifié (le) par CacaoTor

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

  • YouTube / Les Imprimantes 3D .fr

×
×
  • Créer...