Aller au contenu

Filament ABS

yopla31

CR-10 et Ender 5 de Yopla

Messages recommandés

Il y a 1 heure, fran6p a dit :

A la manière de @Jean-Claude Garnier: «moi en électricité. j’y connais que dalle !»

«moi en électricité. j’y connais que dalle !»

                                   (Charlemagne)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, Titi78 a dit :

Il ya aussi un petit module électronique de @Janpolanton qui permet de reguler corectement un ventilateur 12v à partir du 24v 

Attention, je reprécise, il s'agit des fans pilotés pour le refroidissement de l'extrusion, correspondant au paramètre de pourcentage dans le profile du filament.

J'avais cru comprendre que le module de @Janpolanton pilote le ventilateur chargé du refroidissement du corps du hotend ?

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 17/12/2019 at 12:58, yopla31 a dit :

En retravaillant sur ma double tête, je m'aperçois d'un petit problème :

Je suis maintenant en alimentation 24v sur la SKR. Mais j'ai prévu 2 ventilateurs 6015, pour le refroidissement piloté. Malheureusement, ils sont en 12v, et je ne pense me tromper en disant que les sorties pilotées pour les fans :

image.png.3ed63eafdb36c73b40014191aa7e1fd7.png

varie dans la tension de l'alimentation de la carte, de 0v à 24v dans mon cas ! J'ai cherché et j'ai trouvé des 6015 en 24v uniquement sur Aliexp. Donc en attendant de recevoir des fans depuis Aliexp, puis-je brancher en série mes 2 ventilateurs 12v, sur la sortie pilotée ?

Bin NON, gros neuneu 🤓, si tu avais un poil de curiosité, tu fouillerais dans le configuration_adv.h de Marlin v2.0.x et tu tomberais sur :

/**
 * PWM Fan Scaling
 *
 * Define the min/max speeds for PWM fans (as set with M106).
 *
 * With these options the M106 0-255 value range is scaled to a subset
 * to ensure that the fan has enough power to spin, or to run lower
 * current fans with higher current. (e.g., 5V/12V fans with 12V/24V)
 * Value 0 always turns off the fan.
 *
 * Define one or both of these to override the default 0-255 range.
 */
//#define FAN_MIN_PWM 50
#define FAN_MAX_PWM 128

et définissant FAN_MAX_PWM à 128 (256/2=128, au cas tu n'aurais pas compris!), et bien tu piloterais ton fan 12v, "the fingers in the naze noze" avec ton jus en 24v !!

NB: Pour ceusses qui seraient choqués du ton employé et avant qu'un modo me bannisse, je me réponds à moi-même ! 🤪 Et ça pourra servir à d'autre...

Modifié (le) par yopla31
  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 7 heures, Titi78 a dit :

Pour les modules il y a les 2 . Ventilo de hotend asservi à la temperature  et ventilo de refroidissement du filament en sortie de buse 

Merci pour ces bonnes informations.

Je vais opté pour "l'option firmware" plus souple, j'aurai juste à modifier l'option et reflasher dès que j'aurai mes fan 24v. 😉

Ils sont malins Marlin...

Partager ce message


Lien à poster
Partager sur d’autres sites

😫La v2.0.1 de Marlin a un bug au niveau du changement d'outil qui me bloque dans mon projet de dual extrusion. En v1.0.9 avec la GT2560RevA+, ça fonctionnait bien au niveau software (moins bien au niveau mécanique 😀).

Entre les anomalies et délicatesses de la BTT SKR Pro 1.1 et ce bug, ça m'a gavé ! 🤬

Samedi une gentille Duet 2 Wifi est arrivée discrètement à la maison...🙄 Un peu de lecture de doc et ce matin, le support de Duet 2 Wifi était fini d'imprimer, plus qu'à câbler avec les connecteurs Molex à sertir. J'ai fait un câble avec un connecteur jst en accord avec l'existant d'un côté et le connecteur Molex de l'autre, histoire de pouvoir remettre une carte standard facilement. Entre les soudures des connecteurs JST et les sertissages des pins des connecteurs Molex, ça m'a pris la journée ! Mais ce soir test rapide des axes et homing :

  • X après inversion du sens, homing OK
  • Y homing OK
  • Z le BLTouch fonctionne bien, sauf que la position X et Y est en X10 et Y10 ou quelque chose du genre (un paramétrage à refaire)

Les ventilos ne fonctionnent pas, ni ceux de corps de hotends pourtant direct sur l'alim 12v supplémentaire, j'ai dû oublier un branchement, et le fan PWM à vérifier aussi !

Suis content de moi... Après les déboires Marlin/Bigtreetech, ça fait plaisir ! 😉 Il reste du taf, mais je découvre RerapFirmware !

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

J'avance, les mouvements ok, le homing et probing ok, le lit chauffe correctement (220v avec SSR).

J'ai reçu mes fans en 24v, 30x10 et 6015.

Mais problème, les nozzles ne chauffent pas. La température s'affiche correctement, mais ils restent à température ambiante et les 2 leds "Ex Heat" ne s'allument pas 😯. Ils sont connecté en direct , sans mosfet.

image.png.9869458015847562d875d00da69e22b7.png

 

@optik8, @Guizboy, @Lecoyote, qui peut m'aider ? J'ai vérifié mon câblage, mais avec les 2 cartouches chauffantes connectées à la duet, j'ai une continuité sur les 4 contacts !

Modifié (le) par yopla31
  • Triste... 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me répond à moi-même, en partie.

Sur le Tableau de bord :

image.png.c96de2a80f4d77b9b72dce7d667429d0.png

dans la colonne Actif, si je sélectionne (ou entre une valeur), pour le lit, il passe "actif" sous Chauffage 0 :

image.png.7e6eeddae163f2b1cf73416427c17ab0.png et commence la chauffe.

Pour les outils, en entrant une valeur, rien ne se passe. Il faut que je clique sur "Outil 0" pour que son état passe à actif et qu'il chauffe. C'est un peu perturbant, mais ce doit être normal.

Je vais refermer l'engin et continuer les tests puisque le principal fonctionne 😨 Un grand moment de solitude...

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...