Aller au contenu

Filament ABS

CacaoTor

AlfaWise U20x-U30 : Marlin Configuration, Optimisation, Périphériques

Messages recommandés

Bonjour,

J'ai une U20 avec la carter mère de base et j'i donc installé marlin 2.

Tout fonctionne à merveille sauf que comme je la trouve lente par rapport au temps estimé par cura ou simplify, j'ai voulu la boooster un peu en modifiant 2 lignes.

LIGNE 776
#define DEFAULT_MAX_ACCELERATION      { 500, 500, 100, 3000 }                   //avant 200, 200

LIGNE 786
#define DEFAULT_ACCELERATION          500    // X, Y, Z and E acceleration for printing moves     avant 200
#define DEFAULT_RETRACT_ACCELERATION  500    // E acceleration for retracts
#define DEFAULT_TRAVEL_ACCELERATION   500    // X, Y, Z acceleration for travel (non printing) moves avant 200

tout cela sous platetormIO seulement il ne veut pas le compiler.

Quand j'ouvre le terminal et que je fais Run Build Task, j'ai un message d'erreur voir la capture 1, je clique sur le lien capture 2 et j'ai le message d'erreur capture 3

Et si je clique sur le PROBLEMS 1, j'ai ce message :{
    "resource": "/d:/Modelisme/CNC/Imprimante_3D/CARTESIENNE/Alfawise U20/Marlin/Marlin/Configuration.h",
    "owner": "C/C++",
    "code": "1696",
    "severity": 8,
    "message": "Erreurs #include détectées. Mettez à jour includePath. Les tildes sont désactivés pour cette unité de traduction (D:\\Modelisme\\CNC\\Imprimante_3D\\CARTESIENNE\\Alfawise U20\\Marlin\\Marlin\\src\\Marlin.cpp).",
    "source": "C/C++",
    "startLineNumber": 1,
    "startColumn": 1,
    "endLineNumber": 1,
    "endColumn": 1
}

Quel est le problème?

diiity

Sans titre 1.jpg

Sans titre 2.jpg

Sans titre 3.JPG

Modifié (le) par diiity

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour,

j'ai le même problème.

Si je met mets dans le répertoire de base de Marlin via le Terminal(comme le screen du dessus) et que je force la compilation avec la command platformio run, la compilation se termine bien.

Seulement après flashage la machine reste sur les deux barres vertes à fond et se bloque.
Si je force le reboot, Marlin semble se lancer car le BL Touch fait son test, mais écran noir et impossible de se connecter via le câble USB et Octoprint.

J'ai tenté de revenir sur du STM32 vers 5.3 idem.

Versions actuelles:
Visual studio Code 1.41.1
PlateformIO IDE: 1.10.1
STM32: 5.3.0 ou 5.6.0

Une idée ?

Partager ce message


Lien à poster
Partager sur d’autres sites

J ai compilé le tag 2.0.1 ce matin et ça marche. J’imagine qu une mise à jour de platformio ou bien vscode a encore cassé la compil.... le lib stm doit pas poser de problème. Essayez de réinstaller une version plus ancienne de platformio... dec2019...

Partager ce message


Lien à poster
Partager sur d’autres sites

Pour ma part, je n'ai fait aucune mise à jour, j'ai passé ma U20 sous marlin il y a une 15 de jours environ et ça fonctionnait très bien.

Quelques jours après le passage sous marlin, j'ai fait une seconde compilation à cause de la tête baladeuse, et là aussi pas de souci.

et puis voilà j'ai voulu recompiler pour faire des modif de vitesse et là ça plante.

Partager ce message


Lien à poster
Partager sur d’autres sites

Ca y est ça refonctionne !

J'ai commencé par supprimer mes répertoires de données(.vscode et .platformio) dans mon profile utilisateur windows, ce qui reset tout la conf VScode -> Idem
Je suis repassé sur Python 3.7.5 -> Idem
J'ai retrogradé ma version de platformIO IDE -> Idem
J'ai retrogradé ma version de STM32 en 5.3 -> Idem

Au final j'en suis revenu à reprendre la source de Marlin sur git et tenter une compile -> OK

Quelque chose a du mettre la grouille dans mon projet Marlin, pourtant la dernière compile fonctionnait bien.

En espérant que ça ne se reproduise pas 🙂

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 19 heures, Arasstal a dit :

Ca y est ça refonctionne !

J'ai commencé par supprimer mes répertoires de données(.vscode et .platformio) dans mon profile utilisateur windows, ce qui reset tout la conf VScode -> Idem
Je suis repassé sur Python 3.7.5 -> Idem
J'ai retrogradé ma version de platformIO IDE -> Idem
J'ai retrogradé ma version de STM32 en 5.3 -> Idem

Au final j'en suis revenu à reprendre la source de Marlin sur git et tenter une compile -> OK

Quelque chose a du mettre la grouille dans mon projet Marlin, pourtant la dernière compile fonctionnait bien.

En espérant que ça ne se reproduise pas 🙂

En faite, tu as tout supprimé et réinstallé, y compris marlin?

Partager ce message


Lien à poster
Partager sur d’autres sites

Désolé mais c'est quoi le repo ?

sinon ,'en ai trouvé un ici dans un de tes post, page 147, second message, il est bon?

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens de recompiler ça ne fonctionne pas, je n'ai pas de message d'erreur, par contre j'ai ceci dans le terminal avec building qui tourne en permanence

> Executing task in folder Marlin-2.0.2: C:\Users\cnc\.platformio\penv\Scripts\platformio.exe run --environment alfawise_U20 <

Processing alfawise_U20 (platform: ststm32; framework: arduino; board: genericSTM32F103VE)
----------------------------------------------------------------------------------------------------------------------------------
Verbose mode can be enabled via `-v, --verbose` option
CONFIGURATION: https://docs.platformio.org/page/boards/ststm32/genericSTM32F103VE.html
PLATFORM: ST STM32 5.3.0 > STM32F103VE (64k RAM. 512k Flash)
HARDWARE: STM32F103VET6 72MHz, 64KB RAM, 512KB Flash
DEBUG: Current (stlink) External (blackmagic, jlink, stlink)
PACKAGES: toolchain-gccarmnoneeabi 1.70201.0 (7.2.1), framework-arduinoststm32-maple 1.10000.190819 (1.0.0)
Converting Marlin.ino
LDF: Library Dependency Finder -> http://bit.ly/configure-pio-ldf
LDF Modes: Finder ~ chain, Compatibility ~ soft
Looking for TMCStepper library in registry

Partager ce message


Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à ce sujet…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


  • Sur cette page :   0 membre est en ligne

    Aucun utilisateur enregistré regarde cette page.

×
×
  • Créer...