Aller au contenu

Filament ABS

  • 0

Réglage du BLTouch


Question

Bonjour,

J'ai installé un BLTouch sur mon Alfawise U30 Pro, j'ai fait les réglages comme indiqué https://arduiblog.com/2020/06/22/installation-dun-bltouch-sur-lalfawise-u30-pro/

J'ai fait un test, voici ce je j'obtiens à la première couche, il y a un coté qui n'est pas en contact avec le bord.

2.thumb.JPG.ffc609e4487309a9f83b4023fce78627.JPG

 

La seconde couche, enlève la première.

1.thumb.JPG.c6571e3cdd4f3d0add4a95ecf3a064d2.JPG

Quelles sont les réglages qui ne sont pas bon ?

D'avance merci.

Modifié (le) par lynyrd
Lien à poster
Partager sur d’autres sites
  • Réponses 191
  • Created
  • Dernière réponse

Top Posters For This Question

Top Posters For This Question

Popular Posts

@Fl0r1an73 vient d'indiquer qu'il n'avait pas pu mettre à jour son écran comme toi. Donc, on reprend tout depuis le début: tu repars avec ton ancien firmware "Marlin1.1.9_LGT0.3_UxPro_Bltouch"

Salut, Je serai curieux de savoir d'où vient ce Gcode de démarrage (entre mauvais Gcode et Gcode incomplets...😖) Voici une version corrigée: M140 S{material_bed_temper&ature};start heatin

@lynyrd(skynyrd (un rapport avec ce groupe américain ?)), Essaie d'installer l'extension «Auto Build Marlin» via VSC : 🙂

Posted Images

Messages recommandés

  • 0

Ton réglage buse/bed a t-il été soigneusement fait avant l'installation du bltouch ? il doit être "parfait".

On voit sur le coin en bas a gauche que tu es trop proche du bed.

si tu es sur de ton réglage buse bed peut-être as-tu oublié d'enregistrer le mesh bed leveling.

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites
  • 0

Je l'avais réglé quand je l'ai installé avec Pronterface et une feuille de papier, il était bon.

Quand j'ai fait l'essai, j'ai eu ce résultat.

Faut-il recommencer et régler le bed leveling ?

Lien à poster
Partager sur d’autres sites
  • 0
il y a 40 minutes, Idealnight a dit :

Ton réglage buse/bed a t-il été soigneusement fait avant l'installation du bltouch ? il doit être "parfait".

On voit sur le coin en bas a gauche que tu es trop proche du bed.

Relis bien ce que je t'ai noté, je l'ai surligné en gras

Lien à poster
Partager sur d’autres sites
  • 0
il y a 15 minutes, Idealnight a dit :

on réglage buse/bed a t-il été soigneusement fait avant l'installation du bltouch ? il doit être "parfait".

On voit sur le coin en bas a gauche que tu es trop proche du bed.

Oui, je l'ai régler avec une feuille de papier et enregistré, comme indiqué dans le tuto.

Il n'est pas parfait, la question est: dois-je refaire le bed leveling avec Pronterface ?

Lien à poster
Partager sur d’autres sites
  • 0

Non je ne te parle pas du réglage avec le bltouch et l'enregistrement de celui-ci.

Je te parle du réglage manuel que l'on fait avec les molettes en dessous du bed.

Dis nous la procédure que tu as faites exactement avant, pendant et après l'installation physique du bltouch.

Lien à poster
Partager sur d’autres sites
  • 0

J'ai monté le BLTouch sur l'imprimante, fait les réglages dans Marlin, comme indiqué sur le blog posté plus haut https://arduiblog.com/2020/06/22/installation-dun-bltouch-sur-lalfawise-u30-pro/

j'ai ensuite réglé le Home Z avec Pronterface pour le mettre juste en frottement avec une feuille de papier et enregistré les valeurs, toujours comme indiqué sur le blog.

J'ai raté quelque chose ?

Je crois que je vais devoir tout recommencer. 😪

Lien à poster
Partager sur d’autres sites
  • 0

J'ai essayé de faire le réglage comme sur cette vidéo, à partir de la 3", ça ne fonctionne pas,  je fais le G28 Z et la commande suivante ne fonctionne pas.

Lien à poster
Partager sur d’autres sites
  • 0

Bonjour @lynyrd

Lorsque tu fait le réglage manuel de bed avec une feuille de papier :

Tu fait bien a chaud, une fois au centre, puis les 4 coins, (puis si tu a fait des réglages re au centre et re le 4 coins pour bien être ok) ? 

Si tu ne fait qu'un seul point ce n'ai pas suffisant ... on ai d'accord ?

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

Oui, je met le bed à 60°.

Je répète le processus 2 fois, à chaque fois le milieu est trop prés.

Si j'ai installé un BLTouch, c'est pour que justement, je le règle et qu'il compense les défaut du bed.

Lien à poster
Partager sur d’autres sites
  • 0

Ok nikel !

alors après qd tu dit 

il y a 36 minutes, lynyrd a dit :

je fais le G28 Z et la commande suivante ne fonctionne pas

tu parle de la commande G1 F60 Z0 ?

car :

 

G28 Z ; Faire un auto-home de Z donc en principe après cela Z = 0 ! non ?

G1 F60 Z0 ; Aller en Z = 0 avec comme vites max 60 ... en gros cela permet de rester a la même place ! non ?

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)
il y a 13 minutes, PPAC a dit :

tu parle de la commande G1 F60 Z0 ?

De la commande G28 Z,voilà ce que j'ai après:

>>> G28 Z
SENDING:G28 Z
echo:Home XY first

J'ai beau introduire la commande  G1 F60 Z0, rien ne se passe.

>>> G28 Z
SENDING:G28 Z
echo:Home XY first
>>>  G1 F60 Z0
SENDING:G1 F60 Z0

Si avec Pronterface, je fais un home, le BLTouch se trouve au milieu à 20cm du bed

Modifié (le) par lynyrd
Lien à poster
Partager sur d’autres sites
  • 0

Bed a température + Buse ! et trouves le meilleur compromis des 4 coins + centre (en privilégiant le centre) avant de passer au réglage du bltouch par pronterface

Pour le mesh du bltouch via pronterface (dans l'idéal il faut le faire en 25 points c'est a choisir dans le firmware avec un grid 5):

1) G28

2) G29

3) M500

Ensuite le z-offset:

1) G28

2) Ta buse doit être a + 5 ou +10 du bed

3) move axis se mettre a 0

4) Menu motion -> z-offset, faire le réglage avec la feuille

5) M500

Dans ton gcode après le G28 tu ajoutes M420 S1

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites
  • 0

Je ne sais pas régler le bed, aucun réglages n'est possible.

je remet tout à zéro avec la commande

>>> M851 Z0
SENDING:M851 Z0
echo:enqueueing "G1 Z10"
echo:enqueueing "G28"
echo:enqueueing "G1 Z10"
echo:enqueueing "G1 X30 Y30 F3000"
echo:enqueueing "G1 Z0"
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing
echo:busy: processing

la buse est à 3cm du bed

Lien à poster
Partager sur d’autres sites
  • 0

Je suis pas mal largué ... mais je suis sûr q'avec marlin on peut décaler les positions / le référentiel de coordonnée ... se qui explique le Z 0.0 affiché alors que la tête se trouve pas a 0 mm du plateau (voir M206 https://marlinfw.org/docs/gcode/M206.html et G92 https://marlinfw.org/docs/gcode/G092.html)

Normalement on retrouve les  "offsets" / "décalage de référentiel"  dans les affichages d'une commande M503 

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0

Quel firmware as-tu installé ? As-tu réglé le probe ?

Et j'ai tenté vainement de me faire comprendre mais il faut d'abord réglé la machine matériellement !

Tu dois manuellement avec tes doigts en désactivant les moteurs régler le bed et la buse avec les molettes placées en dessous du plateau. Tu fais un home, prends un ticket de caisse ou CB, tu déplaces la tête d'impression en bas a gauche et tu règles avec la molette puis en haut a gauche puis en haut a droite puis en bas a droite puis au centre et tu refais une nouvelle fois et encore une autre si nécessaire.

Et après cela tu passes à la procédure que j'ai citée plus haut.

Lien à poster
Partager sur d’autres sites
  • 0
il y a 2 minutes, Idealnight a dit :

Quel firmware as-tu installé ?

Celui-ci: Marlin1.1.9_LGT0.3.x_Alfawise_Ux0Pro-master.zip

il y a 5 minutes, Idealnight a dit :

Tu dois manuellement avec tes doigts en désactivant les moteurs régler le bed et la buse avec les molettes placées en dessous du plateau.                                                     

Je ne sais pas le faire, la buse ne descend pas et je ne sais pas comment désactiver les moteurs. 😳

Lien à poster
Partager sur d’autres sites
  • 0

En commande g-code M18, M84 - Disable steppers (cf : https://marlinfw.org/docs/gcode/M018.html

sinon via le menu marlin dans "control" y a normalement l'option "Disable motors"

@lynyrd En fait excuse moi c même

le belle icone sur t'on écran ou l'on vois le Z a 0.0 le dessin de moteur avec un légère croix rouge avec écris "désactiver" en dessous !

1.thumb.JPG.6b5ecb1ea04b94b89a95d5a4de55f258_disable_moteur.jpeg.33b71c7bcfd47b3b46815fc32f8ca5cc.jpeg

Puis après tu peux tourner manuellement la tige fileté de l'axe Z pour rapprocher la tête au plateau ...

C'est normal quand on connais pas c'est comme tenter de comprendre une langue étrangère, prend t'on temps, pas de stress, on va y arriver ! faut se dire q'on apprend pleins de truc, que c cela le truc chouette ! Dit nous si y a encore qq chose qui t’échappe ...  

Tu vois moi aussi j'apprend je connais pas la version graphique ...

Modifié (le) par PPAC
Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)
Il y a 20 heures, Idealnight a dit :

Bed a température + Buse ! et trouves le meilleur compromis des 4 coins + centre (en privilégiant le centre) avant de passer au réglage du bltouch par pronterface

Je ne sais régler qu'un coté du Bed , la buse remonte et redescend,ensuite elle se bloque !

Dois-je remettre le firmware corrigé, que j'avais installé quand j'ai fait la configuration de Marlin pour installer le BLTouch, ensuite faire le réglage du Bed manuellement avant d'utiliser Pronterface ?

Modifié (le) par lynyrd
Lien à poster
Partager sur d’autres sites
  • 0

Bon j'ai juste vérifier que les vidéos montraient ce qu'il fallait...

Pour le firmware si ça ne fonctionne pas comme prévu alors qu'avec l'autre oui je pense qu'il faudrait y revenir effectivement.

La première vidéo montre le réglage manuel qu'il faut ABSOLUMENT faire avant de passer au réglage du bltouch:

Ce deuxième lien montre l'installation d'un bltouch sur une U30:

https://arduiblog.com/2020/06/22/installation-dun-bltouch-sur-lalfawise-u30-pro/

Modifié (le) par Idealnight
Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

En ce qui concerne la première vidéo comme dit plus haut, je ne sais pas faire le réglage, au début, la buse est à 10 cm du Bed, je la descend pour la régler, ensuite c'est comme sur la vidéo que j'ai posté, donc impossible de la régler manuellement.

Le second lien, j'ai fait exactement ce qui est indiqué, voilà ce que j'avais après les réglages:

2.thumb.JPG.ebbbb5f5a440edcc49d1eb7e37e0c6f2.JPG

Et la seconde couche:

3.JPG.17b87b7c381332db45e86042b363da60.JPG

Ma question était de savoir si je devais réinjecter le firmware modifié que j'avais transformé et qui me donnait une seconde couche trop basse et ensuite recommencer le réglage du Bed ?

Merci de votre aide.

Modifié (le) par lynyrd
Lien à poster
Partager sur d’autres sites
  • 0
Posté(e) (modifié)

Quand j'essaie de réinstaller Marlin compilé, j'ai un message d'erreur:

F:\Imprimante 3D\Logiciels\Arduino\hardware\arduino\avr\cores\arduino\Print.cpp: In member function 'write':
F:\Imprimante 3D\Logiciels\Arduino\hardware\arduino\avr\cores\arduino\Print.cpp:42:1: internal compiler error: Segmentation fault
 }
 ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <https://gcc.gnu.org/bugs/> for instructions.
lto-wrapper.exe: fatal error: F:\Imprimante 3D\Logiciels\Arduino\hardware\tools\avr/bin/avr-gcc returned 1 exit status
compilation terminated.
f:/imprimante 3d/logiciels/arduino/hardware/tools/avr/bin/../lib/gcc/avr/7.3.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed
collect2.exe: error: ld returned 1 exit status
exit status 1
Erreur de compilation pour la carte Arduino Mega or Mega 2560

Modifié (le) par lynyrd
Lien à poster
Partager sur d’autres sites
  • 0

c'est toujours compliqué les 1er compilation de firmware ... y a tellement de trucs en interaction / interdépendance  ...

Si tu compile avec Arduino, tu pourrais essayer avec VSCode plus PlatformIO https://platformio.org/install/ide?install=vscode cela semble être la solution qui dérape le moins ...Si t deja avec platformIO ... essai de "clean" puis de "build"

Lien à poster
Partager sur d’autres sites
  • 0

si c bien arduino que tu utilise, il semble que de placer les fichiers / le projet le plus proche de la racine aide ... il n'aime pas les long chemins de fichiers,

un Segmentation fault lors d'une compilation c'est souvent une demande trop importante d'espace mémoire indisponible ou une récursions infinie qui bouffe tt la mémoire ... mais cela fait longtemps que j'en avais pas vu ....

Lien à poster
Partager sur d’autres sites

Rejoindre la conversation

Vous pouvez poster un message et vous inscrire plus tard. Si vous avez déjà un compte, connectez-vous afin de poster avec.

Invité
Répondre à cette question…

×   Vous avez copié du contenu avec formatage.   Supprimer le formatage

  Only 75 emoji are allowed.

×   Votre lien a été automatiquement intégré.   Afficher en tant que lien à la place

×   Le contenu sauvegardé a été restauré.   Effacer l'éditeur

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Créer...